summaryrefslogtreecommitdiff
path: root/docs/reference/Makefile.am
diff options
context:
space:
mode:
authorBrian Tarricone <brian@tarricone.org>2007-09-05 08:01:33 +0000
committerBrian Tarricone <brian@tarricone.org>2007-09-05 08:01:33 +0000
commit67e1209d281d1690a4591616a23b10300d0583dd (patch)
treee72e9741089fd66eb527eb01667555852ee26b79 /docs/reference/Makefile.am
parentd8ec8193cf46ef720b8d5394ffa5565ff4206aac (diff)
downloadxfconf-67e1209d281d1690a4591616a23b10300d0583dd.tar.gz
add gtk-doc framework and fix up docs everywhere
(Old svn revision: 26717)
Diffstat (limited to 'docs/reference/Makefile.am')
-rw-r--r--docs/reference/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/docs/reference/Makefile.am b/docs/reference/Makefile.am
new file mode 100644
index 0000000..e246771
--- /dev/null
+++ b/docs/reference/Makefile.am
@@ -0,0 +1,76 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = 1.8
+
+# The name of the module.
+DOC_MODULE=xfconf
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+
+# Extra options to supply to gtkdoc-scan
+SCAN_OPTIONS=--deprecated-guards="XFCE_DISABLE_DEPRECATED"
+
+# The directory containing the source code. Relative to $(srcdir)
+DOC_SOURCE_DIR=../..
+
+# Extra options to supply to gtkdoc-mkdb
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+
+# Extra options to supply to gtkdoc-fixref
+FIXXREF_OPTIONS=
+
+# Used for dependencies
+HFILE_GLOB=$(top_srcdir)/xfconf/*.h $(top_srcdir)/xfconfd/*.h
+CFILE_GLOB=$(top_srcdir)/xfconf/*.c $(top_srcdir)/xfconfd/*.c
+
+# Header files to ignore when scanning
+IGNORE_HFILES= \
+ config.h \
+ xfconf-backend-factory.h \
+ xfconf-backend-perchannel-xml.h \
+ xfconf-daemon.h \
+ xfconf-dbus-bindings.h \
+ xfconf-marshal.h \
+ xfconf-private.h \
+ xfconfd-dbus-server.h
+
+# Extra files to add when scanning (relative to $srcdir)
+EXTRA_HFILES=
+
+# Images to copy into HTML directory
+HTML_IMAGES =
+
+# Extra SGML files that are included by DOC_MAIN_SGML_FILE
+content_files = \
+ version.xml
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed
+# if $(DOC_MODULE).types is non-empty.
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(GLIB_CFLAGS) \
+ $(LIBXFCE4UTIL_CFLAGS) \
+ $(DBUS_CFLAGS) \
+ $(DBUS_GLIB_CFLAGS)
+
+GTKDOC_LIBS = \
+ $(top_builddir)/xfconf/libxfconf-$(LIBXFCONF_VERSION_API).la \
+ $(top_builddir)/xfconfd/xfconfd-xfconf-backend.o
+
+include $(top_srcdir)/gtk-doc.make
+
+# Other files to distribute
+EXTRA_DIST += \
+ version.xml.in
+
+# manual pages
+man_MANS =
+
+if MAINTAINER_MODE
+%.1: %.xml
+ xsltproc -nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+endif
+
+# vi:set ts=8 sw=8 noet ai nocindent syntax=automake: