summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Schermer <nick@xfce.org>2010-01-28 22:19:46 +0100
committerNick Schermer <nick@xfce.org>2010-01-28 22:19:46 +0100
commit3b4a9bfc377c23005ccf71ac3f6a94c5195d5951 (patch)
tree47f7fa0cfb58ba36aa4569fd40f69a8febc48bf6 /Makefile.am
parenta906368b5ba730bc4ce27485e71183234ac1bdb1 (diff)
downloadxfce4-session-3b4a9bfc377c23005ccf71ac3f6a94c5195d5951.tar.gz
Build ChangeLog during make dist.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 617f91e9..c3d084cb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,6 @@ endif
EXTRA_DIST = \
BUGS \
- ChangeLog.pre-xfce-devel \
intltool-extract.in \
intltool-merge.in \
intltool-update.in \
@@ -45,4 +44,13 @@ rpm: dist
rpmbuild -ta $(PACKAGE)-$(VERSION).tar.gz
@rm -f $(PACKAGE)-$(VERSION).tar.gz
+.PHONY: ChangeLog
+
+ChangeLog: Makefile
+ (GIT_DIR=$(top_srcdir)/.git git log > .changelog.tmp \
+ && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) \
+ || (touch ChangeLog; echo 'Git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+
# vi:set ts=8 sw=8 noet ai nocindent: