summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenedikt Meurer <benny@xfce.org>2005-01-27 18:20:05 +0000
committerBenedikt Meurer <benny@xfce.org>2005-01-27 18:20:05 +0000
commit382e348f4b58987abb1e66dd8d1eec74dadbf6bf (patch)
tree3503122742349337d97fc2a54e007e729e27b39f /Makefile.am
parent045e360b1731f1270d87c93a243634e2ca8ae423 (diff)
downloadxfce4-session-382e348f4b58987abb1e66dd8d1eec74dadbf6bf.tar.gz
2005-01-27 Benedikt Meurer <benny@xfce.org>
* Removed autogenerated files from CVS. * Fixed bug #734 by depending on libgnome-2.0, rather than gconf, which pulls in the required path settings. (Old svn revision: 4785)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 16 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 46ad73a4..b782f3fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,5 @@
+@SET_MAKE@
+
SUBDIRS = \
libxfsm \
docs \
@@ -16,28 +18,30 @@ distclean-local:
rm -rf xfce4-session.spec *.cache *~
EXTRA_DIST = \
- $(config_DATA) \
- AUTHORS \
BUGS \
ChangeLog.pre-xfce-devel \
- INSTALL \
- NEWS \
- README \
- TODO \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in \
xfce4-session.spec \
- xfce4-session.spec.in
+ $(config_DATA)
+
+DISTCLEANFILES = \
+ intltool-extract \
+ intltool-merge \
+ intltool-update
html:
- make -C docs html
+ (cd docs && $(MAKE) $(AM_MAKEFLAGS) html)
rpm: dist
rpmbuild -ta $(PACKAGE)-$(VERSION).tar.gz
@rm -f $(PACKAGE)-$(VERSION).tar.gz
-ACLOCAL_AMFLAGS = -I m4
-
dist-bz2: dist
- zcat $(PACKAGE)-$(VERSION).tar.gz | bzip2 --best -c > $(PACKAGE)-$(VERSION).tar.bz2
+ zcat $(PACKAGE)-$(VERSION).tar.gz | \
+ bzip2 --best -c > $(PACKAGE)-$(VERSION).tar.bz2
distcheck-bz2: distcheck
- zcat $(PACKAGE)-$(VERSION).tar.gz | bzip2 --best -c > $(PACKAGE)-$(VERSION).tar.bz2
+ zcat $(PACKAGE)-$(VERSION).tar.gz | \
+ bzip2 --best -c > $(PACKAGE)-$(VERSION).tar.bz2