summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-06-01 17:29:37 +0200
committerRomain Bouvier <skunnyk@alteroot.org>2020-06-04 19:54:45 +0200
commitcaed69490485466132348afe283a2e80ab371ed1 (patch)
tree7b990e85eaf4cae5894a79ff7a7507c38a6511a9 /Makefile.am
parente19cc0f79b3a577ef1e3ab1220c47ed640362a6e (diff)
downloadxfce4-dev-tools-caed69490485466132348afe283a2e80ab371ed1.tar.gz
Implement XDT_VERSION_INIT
Add an XDT_VERSION_INIT help macro that will define a set of version macros using esyscmd so we no lnger need to use configure.ac.in to perpare the version string for AC_INIT. XDT_VERSION_INIT(SEMVER, [TAG] will set the following macros: - xdt_version - xdt_version_major - xdt_version_minor - xdt_version_micro - xdt_version_tag - xdt_version_build - xdt_debug_default Example usage: XDT_VERSION_INIT([4.15.3],[git]) AC_INIT([xfce4-someproject], [xdt_version()]) ... XDT_FEATURE_DEBUG([xdt_debug_default])
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b36ddd9..23212f9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@
# Written for Xfce by Benedikt Meurer <benny@xfce.org>.
#
-ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+ACLOCAL_AMFLAGS = -I m4 -I m4macros ${ACLOCAL_FLAGS}
SUBDIRS = \
docs \