summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Schermer <nick@xfce.org>2010-06-01 17:38:28 +0200
committerNick Schermer <nick@xfce.org>2010-06-01 17:38:28 +0200
commit2e7c1ed40570cb126bacc494540dd04280129501 (patch)
treefd750ca29720dba85d7ba4dc49c69d2a3e8e8fc2 /Makefile.am
parent8997c300eae1fa5c13f27e034cee65d1f571eab8 (diff)
downloadxfce4-appfinder-2e7c1ed40570cb126bacc494540dd04280129501.tar.gz
Build ChangeLog from GIT.
Also drop the po ChangeLog now we use Transifex. Conflicts: ChangeLog
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a0c013..5dcc1fb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,3 +25,12 @@ distclean-local:
rpm: distcheck
rpmbuild -ta $(PACKAGE)-$(VERSION).tar.gz
@rm -f $(PACKAGE)-$(VERSION).tar.gz
+
+.PHONY: ChangeLog
+
+ChangeLog: Makefile
+ (GIT_DIR=$(top_srcdir)/.git git log > .changelog.tmp \
+ && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) \
+ || (touch ChangeLog; echo 'Git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog