summaryrefslogtreecommitdiff
path: root/docs/reference/tumbler/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/reference/tumbler/Makefile.am')
-rw-r--r--docs/reference/tumbler/Makefile.am81
1 files changed, 81 insertions, 0 deletions
diff --git a/docs/reference/tumbler/Makefile.am b/docs/reference/tumbler/Makefile.am
new file mode 100644
index 0000000..cf6e1c1
--- /dev/null
+++ b/docs/reference/tumbler/Makefile.am
@@ -0,0 +1,81 @@
+# vi:set ts=8 sw=8 noet ai nocindent syntax=automake:
+# -
+# Copyright (c) 2009 Jannis Pohlmann <jannis@xfce.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this program; if not, write to the Free
+# Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+#
+
+AUTOMAKE_OPTIONS = 1.8
+
+# Name of the module
+DOC_MODULE=tumbler
+
+# Top-level SGML file
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.xml
+
+SCAN_OPTIONS=--rebuild-sections
+
+# Extra options to pass to gtkdoc-scangobj
+SCANGOBJ_OPTIONS=
+
+# Directory containing the source code
+DOC_SOURCE_DIR=$(top_srcdir)/tumbler
+
+# Extra options to supply to gtkdoc-mkdb
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+
+# Extra options to supply to gtkdoc-fixref
+FIXXREF_OPTIONS=
+
+# Used for dependencies
+HFILE_GLOB=$(top_srcdir)/tumbler/*.h
+CFILE_GLOB=$(top_srcdir)/tumbler/*.c
+
+# Extra files to add when scanning (relative to $srcdir)
+EXTRA_HFILES=
+
+# Images to copy into HTML directory
+HTML_IMAGES =
+
+# Extra SGML files that are included by DOC_MAIN_SGML_FILE
+content_files = \
+ version.xml
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed
+# if $(DOC_MODULE).types is non-empty.
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(DBUS_CFLAGS) \
+ $(DBUS_GLIB_CFLAGS) \
+ $(GIO_CFLAGS) \
+ $(GLIB_CFLAGS) \
+ $(GTHREAD_CFLAGS)
+
+GTKDOC_LIBS = \
+ $(DBUS_LIBS) \
+ $(DBUS_GLIB_LIBS) \
+ $(GIO_LIBS) \
+ $(GLIB_LIBS) \
+ $(GTHREAD_LIBS) \
+ $(GLIB_LIBS) \
+ $(top_srcdir)/tumbler/libtumbler-$(TUMBLER_VERSION_API).la
+
+include $(top_srcdir)/gtk-doc.make
+
+# Other files to distribute
+EXTRA_DIST += \
+ version.xml.in