summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-05-17 03:22:34 +0200
committerJannis Pohlmann <jannis@xfce.org>2009-05-17 03:22:34 +0200
commitf46395f8446a568681ef4b8d61bd2d390a6acc61 (patch)
treedb9bfab55bc1ef783837f6e6b605bb748344dd24 /tumbler/Makefile.am
parent90f017638e119185bf17a373d7d565eaebb8903c (diff)
downloadtumbler-f46395f8446a568681ef4b8d61bd2d390a6acc61.tar.gz
Initial import. Nothing useful yet.
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
new file mode 100644
index 0000000..857b50f
--- /dev/null
+++ b/tumbler/Makefile.am
@@ -0,0 +1,56 @@
+# vi:set ts=8 sw=8 noet ai nocindent:
+#-
+# Copyright (c) 2009 Jannis Pohlmann <jannis@xfce.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this program; if not, write to the Free
+# Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+libexec_PROGRAMS = \
+ tumbler
+
+tumbler_SOURCES = \
+ main.c
+
+tumbler_CFLAGS = \
+ -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
+ -DG_LOG_DOMAIN=\"tumbler\" \
+ $(DBUS_CFLAGS) \
+ $(DBUS_GLIB_CFLAGS) \
+ $(GIO_CFLAGS) \
+ $(GLIB_CFLAGS) \
+ $(GTHREAD_CFLAGS)
+
+tumbler_LDFLAGS = \
+ -no-undefined
+
+tumbler_LDADD = \
+ $(DBUS_LIBS) \
+ $(DBUS_GLIB_LIBS) \
+ $(GIO_LIBS) \
+ $(GLIB_LIBS) \
+ $(GTHREAD_LIBS)
+
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.xfce.Tumbler.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+%.service: %.service.in
+ sed -e "s,\@libexecdir\@,$(libexecdir),g" < $< > $@
+
+CLEANFILES = \
+ $(service_DATA)
+
+EXTRA_DIST = \
+ $(service_in_files)