summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-05-22 01:48:00 +0200
committerJannis Pohlmann <jannis@xfce.org>2009-05-22 01:48:00 +0200
commitefab2f56c73c1dec60a14c83a5aff6a5620f7bbc (patch)
treeb8fcee37105b2228a6d6aff319d2a111643e2d92 /tumbler/Makefile.am
parent2c9ff27c04812b52b4ba9ed02cd1c4c89da9b851 (diff)
downloadtumbler-efab2f56c73c1dec60a14c83a5aff6a5620f7bbc.tar.gz
Add error domain, TumblerThumbnailFlavor and thumbnail helper functions.
This commit adds the TUMBLER_ERROR_DOMAIN and TUMBLER_ERROR defines and a TumblerErrorEnum with currently only containing TUMBLER_ERROR_FAILED. Also new is the TumblerThumbnailFlavor enum type, together with a few utility functions related to creating thumbnails: - tumbler_thumbnail_get_flavors() returns all flavors supported by the current build of tumbler, - tumbler_thumbnail_flavor_get_size() returns the size corresponding to a flavor (e.g. 128 for TUMBLER_THUMBNAIL_FLAVOR_NORMAL), - tumbler_thumbnail_flavor_get_directory() returns a GFile pointing to the flavor directory (e.g. $HOME/.thumbnails/normal/ for TUMBLER_THUMBNAIL_FLAVOR_NORMAL), - tumbler_thumbnail_get_file() returns a GFile pointing to the thumbnail destination file of an URI and a flavor, - tumbler_thumbnail_create_and_open_file() tries to create such a GFile and also tries to open it for writing, returning the GFileOutputStream if possible.
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
index fe16a87..21c22cc 100644
--- a/tumbler/Makefile.am
+++ b/tumbler/Makefile.am
@@ -29,11 +29,16 @@ libtumbler_built_sources = \
libtumbler_headers = \
tumbler-config.h \
- tumbler-marshal.h
+ tumbler-enum-types.h \
+ tumbler-error.h \
+ tumbler-marshal.h \
+ tumbler-thumbnail.h
libtumbler_sources = \
tumbler-config.c \
- tumbler-marshal.c
+ tumbler-enum-types.c \
+ tumbler-marshal.c \
+ tumbler-thumbnail.c
libtumblerincludedir = $(includedir)/tumbler-$(TUMBLER_VERSION_API)/tumbler