summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-10-14 14:30:55 +0200
committerJannis Pohlmann <jannis@xfce.org>2009-10-14 14:30:55 +0200
commitdde5678ffb9e97c0664210e15220e2b25bc1e66b (patch)
treecda3565c75fdd584c3f59cf68ff41c8de300e8dd /tumbler/Makefile.am
parent7afa5c9ca5f8718fdbef923e447438f1b8473b65 (diff)
downloadtumbler-dde5678ffb9e97c0664210e15220e2b25bc1e66b.tar.gz
Use silent build rules if available.
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am40
1 files changed, 22 insertions, 18 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
index 9ff6d2c..e1d53ed 100644
--- a/tumbler/Makefile.am
+++ b/tumbler/Makefile.am
@@ -114,23 +114,27 @@ tumbler-marshal.h: stamp-tumbler-marshal.h
@true
stamp-tumbler-marshal.h: tumbler-marshal.list Makefile
- cd $(top_builddir)/tumbler \
- && echo "#ifndef __TUMBLER_MARSHAL_H__" > xgen-emh \
- && echo "#define __TUMBLER_MARSHAL_H__" >> xgen-emh \
- && ( glib-genmarshal \
- --prefix=tumbler_marshal \
- --header $(srcdir)/tumbler-marshal.list ) >> xgen-emh \
- && echo "#endif /* !__TUMBLER_MARSHAL_H__ */" >> xgen-emh \
- && ( cmp -s xgen-emh tumbler-marshal.h \
- || cp xgen-emh tumbler-marshal.h ) \
- && rm -f xgen-emh \
- && echo timestamp > $(@F)
+ $(AM_V_GEN) ( \
+ cd $(top_builddir)/tumbler \
+ && echo "#ifndef __TUMBLER_MARSHAL_H__" > xgen-emh \
+ && echo "#define __TUMBLER_MARSHAL_H__" >> xgen-emh \
+ && ( glib-genmarshal \
+ --prefix=tumbler_marshal \
+ --header $(srcdir)/tumbler-marshal.list ) >> xgen-emh \
+ && echo "#endif /* !__TUMBLER_MARSHAL_H__ */" >> xgen-emh \
+ && ( cmp -s xgen-emh tumbler-marshal.h \
+ || cp xgen-emh tumbler-marshal.h ) \
+ && rm -f xgen-emh \
+ && echo timestamp > $(@F) \
+ )
tumbler-marshal.c: tumbler-marshal.list Makefile
- cd $(top_builddir)/tumbler \
- && echo "#include <tumbler/tumbler-marshal.h>" > xgen-emc \
- && ( glib-genmarshal \
- --prefix=tumbler_marshal \
- --body $(srcdir)/tumbler-marshal.list ) >> xgen-emc \
- && cp xgen-emc tumbler-marshal.c \
- && rm -f xgen-emc
+ $(AM_V_GEN) ( \
+ cd $(top_builddir)/tumbler \
+ && echo "#include <tumbler/tumbler-marshal.h>" > xgen-emc \
+ && ( glib-genmarshal \
+ --prefix=tumbler_marshal \
+ --body $(srcdir)/tumbler-marshal.list ) >> xgen-emc \
+ && cp xgen-emc tumbler-marshal.c \
+ && rm -f xgen-emc \
+ )