summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorGaël Bonithon <gael@xfce.org>2021-12-29 10:48:14 +0100
committerGaël Bonithon <gael@xfce.org>2021-12-29 13:09:43 +0100
commit7fdab65f7a2144a7cae4d49bea13cea3644dfc3c (patch)
tree8bf0045d59c05be0f26d78ffb4756e4e9ddfa997 /tumbler/Makefile.am
parent270289b3a3f2f9ac7891f26135bae6d5e574c868 (diff)
downloadtumbler-7fdab65f7a2144a7cae4d49bea13cea3644dfc3c.tar.gz
desktop-thumbnailer: Allow to override configuration in desktop files
The "X-Tumbler Settings" group is searched in each desktop file with the same keys as in `tumbler.rc`, where the default configuration is now. Closes #52.
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
index 8554e1b..af32d7e 100644
--- a/tumbler/Makefile.am
+++ b/tumbler/Makefile.am
@@ -83,6 +83,7 @@ libtumbler_1_la_CFLAGS = \
$(GLIB_CFLAGS) \
$(GMODULE_CFLAGS) \
$(GTHREAD_CFLAGS) \
+ $(LIBXFCE4UTIL_CFLAGS) \
$(PLATFORM_CFLAGS) \
$(PLATFORM_CPPFLAGS)
@@ -97,7 +98,8 @@ libtumbler_1_la_LIBADD = \
$(GIO_LIBS) \
$(GLIB_LIBS) \
$(GMODULE_LIBS) \
- $(GTHREAD_LIBS)
+ $(GTHREAD_LIBS) \
+ $(LIBXFCE4UTIL_LIBS)
EXTRA_DIST = \
tumbler-config.h.in \