summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-10-08 13:51:22 +0200
committerJannis Pohlmann <jannis@xfce.org>2009-10-08 13:51:22 +0200
commit7f6e40bd038bc56fc6b0cb307914b291ab5583d3 (patch)
treec47514c01f7203bea6c77d816a98217aa61fd7dd /tumbler/Makefile.am
parent48e0e7aea3baa73f37a29bf4c866a0f9aedc2560 (diff)
downloadtumbler-7f6e40bd038bc56fc6b0cb307914b291ab5583d3.tar.gz
$(builddir) doesn't work in Maemo scratchbox, using $(top_builddir)
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
index 9c33e47..6ca5f14 100644
--- a/tumbler/Makefile.am
+++ b/tumbler/Makefile.am
@@ -114,20 +114,20 @@ tumbler-marshal.h: stamp-tumbler-marshal.h
@true
stamp-tumbler-marshal.h: tumbler-marshal.list Makefile
- cd $(builddir) \
+ cd $(top_builddir)/tumbler \
&& echo "#ifndef __TUMBLER_MARSHAL_H__" > xgen-emh \
&& echo "#define __TUMBLER_MARSHAL_H__" >> xgen-emh \
&& ( glib-genmarshal \
--prefix=tumbler_marshal \
--header $(srcdir)/tumbler-marshal.list ) >> xgen-emh \
- && echo "#endif /* !__TUMBLER_MARSHAL_H__ */" >> xgen-emh \
+ && echo "#endif /*! __TUMBLER_MARSHAL_H__ */" >> xgen-emh \
&& ( cmp -s xgen-emh tumbler-marshal.h \
|| cp xgen-emh tumbler-marshal.h ) \
&& rm -f xgen-emh \
&& echo timestamp > $(@F)
tumbler-marshal.c: tumbler-marshal.list Makefile
- cd $(builddir) \
+ cd $(top_builddir)/tumbler \
&& echo "#include <tumbler/tumbler-marshal.h>" > xgen-emc \
&& ( glib-genmarshal \
--prefix=tumbler_marshal \