summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-10-26 22:36:08 +0100
committerJannis Pohlmann <jannis@xfce.org>2009-10-26 22:36:08 +0100
commit7a1e43d0806ec976eb2872209affb3d8a0dad7d0 (patch)
treeb4dbedbee9a6c10e1a556b38ffa9f257963d409e /tumbler/Makefile.am
parent8258763e662bc2345051f230f2afc4b6da699726 (diff)
downloadtumbler-7a1e43d0806ec976eb2872209affb3d8a0dad7d0.tar.gz
Switch to a plugin API that only allows one cache backend at a time.
Tumbler will now only check for the file $(libdir)/tumbler-1/plugins/cache/tumbler-cache-plugin.so which is supposed to link to the cache backend that is being used. If the XDG cache is built, tumbler-cache-plugin.so is set up to link to this plugin. The fact that we only have a singleton cache makes things much less ambiguous.
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
index 3d32f4d..12f8d0b 100644
--- a/tumbler/Makefile.am
+++ b/tumbler/Makefile.am
@@ -30,7 +30,7 @@ libtumbler_built_sources = \
libtumbler_headers = \
tumbler-abstract-thumbnailer.h \
tumbler-cache.h \
- tumbler-cache-provider.h \
+ tumbler-cache-plugin.h \
tumbler-config.h \
tumbler-enum-types.h \
tumbler-error.h \
@@ -48,7 +48,7 @@ libtumbler_headers = \
libtumbler_sources = \
tumbler-abstract-thumbnailer.c \
tumbler-cache.c \
- tumbler-cache-provider.c \
+ tumbler-cache-plugin.c \
tumbler-config.c \
tumbler-enum-types.c \
tumbler-file-info.c \