summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-06-12 01:01:42 +0200
committerJannis Pohlmann <jannis@xfce.org>2009-06-12 01:01:42 +0200
commit32eb2981f5d35f835809fc05ddc1800bd62c7675 (patch)
tree53e17e68b2ba73441a07d6f5b392780e86926510 /tumbler/Makefile.am
parent4769ddb2dd7c51d8df89f55bbddc91ce7358bfa1 (diff)
downloadtumbler-32eb2981f5d35f835809fc05ddc1800bd62c7675.tar.gz
No thumbnails for thumbnails. Allow Unqueue in the middle of requests.
There's a new method tumbler_cache_is_thumbnail() now which has to be implemented by plugins. It is used by TumblerFileInfo in tumbler_file_info_load() to check whether the file is a thumbnail itself. In that case, tumbler_file_info_load() will fail with a TUMBLER_ERROR_IS_THUMBNAIL error. Add another check in TumblerThresholdScheduler to make unqueuing requests in the middle of the process work.
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
index 1a6233b..e8c9eb7 100644
--- a/tumbler/Makefile.am
+++ b/tumbler/Makefile.am
@@ -41,7 +41,8 @@ libtumbler_headers = \
tumbler-provider-plugin.h \
tumbler-thumbnailer-provider.h \
tumbler-thumbnailer.h \
- tumbler-thumbnail.h
+ tumbler-thumbnail.h \
+ tumbler.h
libtumbler_sources = \
tumbler-abstract-thumbnailer.c \