summaryrefslogtreecommitdiff
path: root/tumbler/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-05-21 13:31:29 +0200
committerJannis Pohlmann <jannis@xfce.org>2009-05-21 13:31:29 +0200
commit28e782dfe7df25e2e41a319d44c32a61644ae44e (patch)
tree630e0896a9c6c75dfa9dcbc013df091b7df4979a /tumbler/Makefile.am
parent233d958a6630d4972fdd2c24c72bab6b9a7b5d01 (diff)
downloadtumbler-28e782dfe7df25e2e41a319d44c32a61644ae44e.tar.gz
Add tumbler utility library, rename the service to tumblerd.
There's a library called tumbler (or tumbler-1) now which provides utility classes and functions for writing specialized thumbnailers. The libary is LGPL while the D-Bus service itself is GPL. The tumbler service was renamed to tumblerd and the marshallers were moved into the library.
Diffstat (limited to 'tumbler/Makefile.am')
-rw-r--r--tumbler/Makefile.am109
1 files changed, 45 insertions, 64 deletions
diff --git a/tumbler/Makefile.am b/tumbler/Makefile.am
index d733d95..fe16a87 100644
--- a/tumbler/Makefile.am
+++ b/tumbler/Makefile.am
@@ -17,82 +17,69 @@
# Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
# Boston, MA 02110-1301, USA.
-libexec_PROGRAMS = \
- tumbler
-
-tumbler_built_sources = \
- tumbler-manager-dbus-bindings.h \
- tumbler-marshal.c \
- tumbler-marshal.h \
- tumbler-service-dbus-bindings.h
-
-tumbler_SOURCES = \
- main.c \
- tumbler-builtin-thumbnailers.c \
- tumbler-builtin-thumbnailers.h \
- tumbler-builtin-thumbnailer.c \
- tumbler-builtin-thumbnailer.h \
- tumbler-manager.c \
- tumbler-manager.h \
- tumbler-naive-scheduler.c \
- tumbler-naive-scheduler.h \
- tumbler-registry.c \
- tumbler-registry.h \
- tumbler-scheduler.c \
- tumbler-scheduler.h \
- tumbler-service.c \
- tumbler-service.h \
- tumbler-specialized-thumbnailer.c \
- tumbler-specialized-thumbnailer.h \
- tumbler-threshold-scheduler.c \
- tumbler-threshold-scheduler.h \
- tumbler-thumbnailer.c \
- tumbler-thumbnailer.h \
- tumbler-utils.h \
- $(tumbler_built_sources)
+lib_LTLIBRARIES = \
+ libtumbler-1.la
+
+libtumbler_built_public_sources = \
+ tumbler-marshal.h
+
+libtumbler_built_sources = \
+ $(libtumbler_built_public_sources) \
+ tumbler-marshal.c
+
+libtumbler_headers = \
+ tumbler-config.h \
+ tumbler-marshal.h
+
+libtumbler_sources = \
+ tumbler-config.c \
+ tumbler-marshal.c
+
+libtumblerincludedir = $(includedir)/tumbler-$(TUMBLER_VERSION_API)/tumbler
+
+libtumblerinclude_HEADERS = \
+ $(libtumbler_headers)
+
+libtumbler_1_la_SOURCES = \
+ $(libtumbler_sources) \
+ $(libtumbler_headers)
-tumbler_CFLAGS = \
+libtumbler_1_la_CFLAGS = \
+ -DDATADIR=\"$(datadir)\" \
-DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
-DG_LOG_DOMAIN=\"tumbler\" \
+ -DTUMBLER_COMPILATION \
+ -DTUMBLER_VERSION_API=\"$(TUMBLER_VERSION_API)\" \
-I$(top_srcdir) \
- $(DBUS_CFLAGS) \
- $(DBUS_GLIB_CFLAGS) \
- $(GDK_PIXBUF_CFLAGS) \
$(GIO_CFLAGS) \
$(GLIB_CFLAGS) \
- $(GTHREAD_CFLAGS)
+ $(GTHREAD_CFLAGS) \
+ $(PLATFORM_CFLAGS)
-tumbler_LDFLAGS = \
- -no-undefined
+libtumbler_1_la_LDFLAGS = \
+ -no-undefined \
+ -export-dynamic \
+ -version-info $(TUMBLER_VERINFO) \
+ $(PLATFORM_LDFLAGS)
-tumbler_LDADD = \
- $(DBUS_LIBS) \
- $(DBUS_GLIB_LIBS) \
- $(GDK_PIXBUF_LIBS) \
+libtumbler_1_la_LIBADD = \
$(GIO_LIBS) \
$(GLIB_LIBS) \
$(GTHREAD_LIBS)
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.xfce.Tumbler.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-
-%.service: %.service.in
- sed -e "s,\@libexecdir\@,$(libexecdir),g" < $< > $@
-
-CLEANFILES = \
- $(service_DATA)
-
EXTRA_DIST = \
- $(service_in_files) \
- tumbler-manager-dbus.xml \
- tumbler-service-dbus.xml
+ tumbler-config.h.in
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = tumbler-1.pc
if MAINTAINER_MODE
DISTCLEANFILES = \
stamp-tumbler-marshal.h \
- $(tumbler_built_sources)
+ tumbler-1.pc \
+ tumbler-config.h \
+ $(libtumbler_built_sources)
BUILT_SOURCES = \
$(tumbler_built_sources)
@@ -115,10 +102,4 @@ tumbler-marshal.c: tumbler-marshal.list Makefile
&& cp xgen-emc tumbler-marshal.c \
&& rm -f xgen-emc
-tumbler-manager-dbus-bindings.h: tumbler-manager-dbus.xml Makefile
- dbus-binding-tool --mode=glib-server --prefix=tumbler_manager $< > $@
-
-tumbler-service-dbus-bindings.h: tumbler-service-dbus.xml Makefile
- dbus-binding-tool --mode=glib-server --prefix=tumbler_service $< > $@
-
endif