summaryrefslogtreecommitdiff
path: root/plugins/cover-thumbnailer/Makefile.am
diff options
context:
space:
mode:
authorNick Schermer <nick@xfce.org>2012-12-11 20:56:25 +0100
committerNick Schermer <nick@xfce.org>2012-12-27 11:28:27 +0100
commit72a8b6ad2af67a2455ac0da78a9304138a35c429 (patch)
treed2b48f9ab4ec8c8f62ed1d491264a2399700ffc1 /plugins/cover-thumbnailer/Makefile.am
parentf2dba5074031aa2faa447ec30ac107debdda7f26 (diff)
downloadtumbler-72a8b6ad2af67a2455ac0da78a9304138a35c429.tar.gz
Add cover-thumbnailer for movies.
Thumbnailer that tries to download the poster of the movie and use it as thumbnail. Plugin send local information over the internet, so you need to explicitly enable the plugin using an rc file. See http://docs.xfce.org/xfce/thunar/tumbler
Diffstat (limited to 'plugins/cover-thumbnailer/Makefile.am')
-rw-r--r--plugins/cover-thumbnailer/Makefile.am64
1 files changed, 64 insertions, 0 deletions
diff --git a/plugins/cover-thumbnailer/Makefile.am b/plugins/cover-thumbnailer/Makefile.am
new file mode 100644
index 0000000..7ffb891
--- /dev/null
+++ b/plugins/cover-thumbnailer/Makefile.am
@@ -0,0 +1,64 @@
+# vi:set ts=8 sw=8 noet ai nocindent:
+# -
+# Copyright (c) 2012 Nick Schermer <nick@xfce.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this program; if not, write to the Free
+# Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+if TUMBLER_COVER_THUMBNAILER
+
+tumbler_plugindir = $(libdir)/tumbler-$(TUMBLER_VERSION_API)/plugins
+tumbler_plugin_LTLIBRARIES = \
+ tumbler-cover-thumbnailer.la
+
+tumbler_cover_thumbnailer_la_SOURCES = \
+ cover-thumbnailer-plugin.c \
+ cover-thumbnailer-provider.c \
+ cover-thumbnailer-provider.h \
+ cover-thumbnailer.c \
+ cover-thumbnailer.h
+
+tumbler_cover_thumbnailer_la_CFLAGS = \
+ -I$(top_builddir) \
+ -I$(top_builddir)/plugins \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/plugins \
+ -DG_LOG_DOMAIN=\"tumbler-cover-thumbnailer\" \
+ -DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
+ $(GDK_PIXBUF_CFLAGS) \
+ $(GIO_CFLAGS) \
+ $(GLIB_CFLAGS) \
+ $(CURL_CFLAGS) \
+ $(PLATFORM_CFLAGS) \
+ $(PLATFORM_CPPFLAGS)
+
+tumbler_cover_thumbnailer_la_LDFLAGS = \
+ -avoid-version \
+ -export-dynamic \
+ -module \
+ $(PLATFORM_LDFLAGS)
+
+tumbler_cover_thumbnailer_la_LIBADD = \
+ $(top_builddir)/tumbler/libtumbler-$(TUMBLER_VERSION_API).la \
+ $(GDK_PIXBUF_LIBS) \
+ $(GIO_LIBS) \
+ $(GLIB_LIBS) \
+ $(CURL_LIBS) \
+ -lm
+
+tumbler_cover_thumbnailer_la_DEPENDENCIES = \
+ $(top_builddir)/tumbler/libtumbler-$(TUMBLER_VERSION_API).la
+
+endif