summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-10-27 03:13:42 +0100
committerJannis Pohlmann <jannis@xfce.org>2009-10-27 03:13:42 +0100
commitae5d1fcdbd406efa945a9ff631991bc08b1fa31e (patch)
tree378f5aea375c541221a62fe6ed468c383d6c0dcc /configure.ac
parent7a1e43d0806ec976eb2872209affb3d8a0dad7d0 (diff)
downloadtumbler-ae5d1fcdbd406efa945a9ff631991bc08b1fa31e.tar.gz
Massive refactoring to support flavors properly.
Refactor the entire code to use TumblerFileInfo instead of separate URI/MIME/flavor arrays. We now support flavors which means that applications can request "normal" and "large" thumbnails and thus have more control over what is created. This simplifies the code in a lot of places. We now use a real GObject class called TumblerThumbnailFlavor instead of a fixed-size enum. Cache backends can return as many flavors as they want, each consisting of a name, a width and a height. As a consequence, we can also get rid of the configure flags to enable/disable normal, large and cropped thumbnails. The default cache plugin shipped with Tumbler only supports "normal" (128x128px) and "large" (256x256px). Optimize the code a little bit. We now load the TunarFileInfo and ThunarThumbnail only *once* for each URI instead of loading them once in the scheduler and again in thumbnailer plugins. This needs careful testing. I might have introduced a few memory leaks here and there, plus new bugs... you never know.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 0 insertions, 45 deletions
diff --git a/configure.ac b/configure.ac
index 81bd15c..e24ea92 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,33 +152,6 @@ TUMBLER_PIXBUF_THUMBNAILER()
TUMBLER_FONT_THUMBNAILER()
TUMBLER_XDG_CACHE()
-dnl ************************************************************
-dnl *** Check for thumbnail flavors (normal, large, cropped) ***
-dnl ************************************************************
-AC_ARG_ENABLE([normal-thumbnails],
- [AC_HELP_STRING([--enable-normal-thumbnails],
- [Enable normal thumbnails (128 pixels) @<:@default=yes@:>@])],,
- [enable_normal_thumbnails=yes])
-if test x"$enable_normal_thumbnails" = x"yes"; then
- AC_DEFINE([ENABLE_NORMAL_THUMBNAILS], [1], [Define if built with support for normal thumbnails])
-fi
-
-AC_ARG_ENABLE([large-thumbnails],
- [AC_HELP_STRING([--enable-large-thumbnails],
- [Enable large thumbnails (256 pixels) @<:@default=no@:>@])],,
- [enable_large_thumbnails=no])
-if test x"$enable_large_thumbnails" = x"yes"; then
- AC_DEFINE([ENABLE_LARGE_THUMBNAILS], [1], [Define if built with support for large thumbnails])
-fi
-
-AC_ARG_ENABLE([cropped-thumbnails],
- [AC_HELP_STRING([--enable-cropped-thumbnails],
- [Enable cropped thumbnails (124 pixels) @<:@default=no@:>@])],,
- [enable_cropped_thumbnails=no])
-if test x"$enable_cropped_thumbnails" = x"yes"; then
- AC_DEFINE([ENABLE_CROPPED_THUMBNAILS], [1], [Define if built with support for cropped thumbnails])
-fi
-
dnl ***********************************
dnl *** Check for debugging support ***
dnl ***********************************
@@ -238,21 +211,3 @@ else
echo " * Freedesktop.org cache plugin: no"
fi
echo
-echo "Supported Thumbnail Flavors:"
-echo
-if test x"$enable_normal_thumbnails" = x"yes"; then
-echo " * Normal (128 pixels): yes"
-else
-echo " * Normal (128 pixels): no"
-fi
-if test x"$enable_large_thumbnails" = x"yes"; then
-echo " * Large (256 pixels): yes"
-else
-echo " * Large (256 pixels): no"
-fi
-if test x"$enable_cropped_thumbnails" = x"yes"; then
-echo " * Cropped (124 pixels): yes"
-else
-echo " * Cropped (124 pixels): no"
-fi
-echo