summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Schermer <nick@xfce.org>2012-12-11 20:56:25 +0100
committerNick Schermer <nick@xfce.org>2012-12-27 11:28:27 +0100
commit72a8b6ad2af67a2455ac0da78a9304138a35c429 (patch)
treed2b48f9ab4ec8c8f62ed1d491264a2399700ffc1 /configure.ac
parentf2dba5074031aa2faa447ec30ac107debdda7f26 (diff)
downloadtumbler-72a8b6ad2af67a2455ac0da78a9304138a35c429.tar.gz
Add cover-thumbnailer for movies.
Thumbnailer that tries to download the poster of the movie and use it as thumbnail. Plugin send local information over the internet, so you need to explicitly enable the plugin using an rc file. See http://docs.xfce.org/xfce/thunar/tumbler
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f41c3a3..084a62e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -151,6 +151,7 @@ PKG_CHECK_MODULES([DBUS_GLIB], [dbus-glib-1 >= 0.72])
dnl *************************
dnl *** Check for plugins ***
dnl *************************
+TUMBLER_COVER_THUMBNAILER()
TUMBLER_FONT_THUMBNAILER()
TUMBLER_JPEG_THUMBNAILER()
TUMBLER_PIXBUF_THUMBNAILER()
@@ -184,6 +185,7 @@ docs/reference/Makefile
docs/reference/tumbler/Makefile
docs/reference/tumbler/version.xml
plugins/Makefile
+plugins/cover-thumbnailer/Makefile
plugins/font-thumbnailer/Makefile
plugins/gst-thumbnailer/Makefile
plugins/jpeg-thumbnailer/Makefile
@@ -206,7 +208,7 @@ dnl ***************************
echo
echo "Build Configuration:"
echo
-echo " * Debug: $enable_debug"
+echo " * Debug: $enable_debug"
echo
echo "Plugins:"
echo
@@ -215,6 +217,11 @@ echo " * GdkPixbuf thumbnailer plugin: yes"
else
echo " * GdkPixbuf thumbnailer plugin: no"
fi
+if test x"$ac_tumbler_cover_thumbnailer" = x"yes"; then
+echo " * Cover thumbnailer plugin: yes"
+else
+echo " * Cover thumbnailer plugin: no"
+fi
if test x"$ac_tumbler_font_thumbnailer" = x"yes"; then
echo " * FreeType font thumbnailer plugin: yes"
else