summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAli Abdallah <aliovx@gmail.com>2015-10-08 20:10:32 +0200
committerAli Abdallah <aliovx@gmail.com>2015-10-08 20:10:32 +0200
commit1f9899cad6ba2f6bae6722db605de41ba474f1b9 (patch)
tree7d117201127c33bc463a24355543e284d3caabfc /configure.ac
parent6b0983ef1bf390c33e919e2086e9be50b4ff8752 (diff)
downloadtumbler-1f9899cad6ba2f6bae6722db605de41ba474f1b9.tar.gz
Start porting some code from dbus-glib.
TumblerManager object which exports the interface 'org.freedesktop.thumbnails.Manager1' is almost dbus-glib free now. There is still only a dbus-glib legacy_connection used for the TumblerSpecializedThumbnailer, which will go away one that object is ported.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8dc277..e612502 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,10 +140,22 @@ if test x"$DBUS_BINDING_TOOL" = x"no"; then
fi
dnl ***********************************
+dnl *** Check for gdbus-codegen ***
+dnl ***********************************
+AC_ARG_VAR([GDBUS_CODEGEN], [D-Bus code and documentation generator from XML D-Bus interface definitions])
+AC_PATH_PROG([GDBUS_CODEGEN], [gdbus-codegen], [no])
+if test x"$GDBUS_CODEGEN" = x"no"; then
+ AC_MSG_ERROR([could not find gdbus-codegen in \$PATH. You can run
+ ./configure GDBUS_CODEGEN=/path/to/gdbus-codegen to define
+ a custom location for it.])
+fi
+
+dnl ***********************************
dnl *** Check for required packages ***
dnl ***********************************
PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.16.0])
PKG_CHECK_MODULES([GIO], [gio-2.0 >= 2.16.0])
+PKG_CHECK_MODULES([GIO_UNIX], [gio-unix-2.0 >= 2.16.0])
PKG_CHECK_MODULES([GMODULE], [gmodule-2.0 >= 2.10.0])
PKG_CHECK_MODULES([GTHREAD], [gthread-2.0 >= 2.16.0])
PKG_CHECK_MODULES([DBUS], [dbus-1 >= 1.0.0])