summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Schermer <nick@xfce.org>2011-12-04 13:20:55 +0100
committerNick Schermer <nick@xfce.org>2011-12-04 13:20:55 +0100
commita40977608707148f7fe3e08de17a738cda83c868 (patch)
treeb8a0b577fe7b968fb4a3c617cd0bfae7e6b03a84 /Makefile.am
parent1fbe3a6b8b7c27be2b97d770c23f606d78a67b99 (diff)
downloadtumbler-a40977608707148f7fe3e08de17a738cda83c868.tar.gz
Auto generate the ChangeLog.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b471695..9d93e30 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,5 +24,14 @@ SUBDIRS = \
tumblerd \
docs
+.PHONY: ChangeLog
+
+ChangeLog: Makefile
+ (GIT_DIR=$(top_srcdir)/.git git log > .changelog.tmp \
+ && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) \
+ || (touch ChangeLog; echo 'Git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+
DISTCHECK_CONFIGURE_FLAGS = \
--enable-gtk-doc