summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2009-06-08 20:31:41 +0200
committerJannis Pohlmann <jannis@xfce.org>2009-06-08 20:31:41 +0200
commit9d5f1b7b03bd0ad50365fa8186a0d9bce690f31d (patch)
tree9aed893b732fd3266c52fdbed77a1ac754199879 /Makefile.am
parent04bb883f2b53aea6f848672ee7dea42cf7a6af86 (diff)
downloadtumbler-9d5f1b7b03bd0ad50365fa8186a0d9bce690f31d.tar.gz
Add plugin interface for cache and thumbnailer implementations.
This is a major refactoring of the source code. Amongst others, the classes TumblerProviderFactory, TumblerThumbnailer, TumblerAbstractThumbnailer, TumblerThumbnailerProvider, TumblerCache, TumblerCacheProvider and TumblerFileInfo have been added. From now on tumbler supports different storage backends and thumbnailers as plugins. Storage backends have to implement TumblerCache, thumbnailers have to implement TumblerThumbnailer. Plugins have to implement three methods: tumbler_plugin_initialize(), tumbler_plugin_shutdown() and tumbler_plugin_get_types(). The latter is expected to return a list of provider types for cache or thumbnailer implementations. Two example plugins have been added, one for the XDG thumbnail cache and one for a GdkPixbuf based thumbnailer. The code of tumblerd was updated to reflect these changes in libtumbler.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 32e08f5..d52e936 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,7 @@
SUBDIRS = \
docs \
+ plugins \
po \
tumbler \
tumblerd