summaryrefslogtreecommitdiff
path: root/icons/Makefile.am
diff options
context:
space:
mode:
authorBenedikt Meurer <benny@xfce.org>2006-04-09 17:40:51 +0000
committerBenedikt Meurer <benny@xfce.org>2006-04-09 17:40:51 +0000
commit12ad2dd246af9e43d1040df9316d714873ca7c21 (patch)
treef2b7492b2a4a3c81b7fb28d60d8b9838e0da7968 /icons/Makefile.am
parent12d3b1c78fc98c3a0a063c9038acfebb1f7dee75 (diff)
downloadthunar-12ad2dd246af9e43d1040df9316d714873ca7c21.tar.gz
2006-04-09 Benedikt Meurer <benny@xfce.org>
* icons/Makefile.am: Be sure to run gtk-update-icon-cache after installing new icons into the hicolor icon theme (skipped if $DESTDIR is set). (Old svn revision: 20832)
Diffstat (limited to 'icons/Makefile.am')
-rw-r--r--icons/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/icons/Makefile.am b/icons/Makefile.am
index c9a589c3..d6a95bea 100644
--- a/icons/Makefile.am
+++ b/icons/Makefile.am
@@ -6,4 +6,17 @@ SUBDIRS = \
48x48 \
scalable
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. Remember to run:"; \
+ echo "***"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ echo "***"; \
+ fi
+
# vi:set ts=8 sw=8 noet ai nocindent syntax=automake: