summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenedikt Meurer <benny@xfce.org>2006-03-01 15:43:43 +0000
committerBenedikt Meurer <benny@xfce.org>2006-03-01 15:43:43 +0000
commitf838d0e4d8462e341405deb5271e5e432e3c6a9a (patch)
treeb7d32f60b030c5a8f708025413fdf2aade75909a /Makefile.am
parent3c53605985f4e67eb6584d3239b08e0432510eff (diff)
downloadthunar-f838d0e4d8462e341405deb5271e5e432e3c6a9a.tar.gz
2006-03-01 Benedikt Meurer <benny@xfce.org>
* docs/manual/C/Thunar.xml.in: Add "Frequently Asked Questions". * thunar/thunar-location-buttons.c(thunar_location_buttons_clicked): Make sure the new active button is visible on the location button bar. * ThunarHelp.in, Makefile.am: Add ThunarHelp script, which is used to display the Thunar user manual. * thunar/thunar-dialogs.{c,h}, thunar/Makefile.am: Add new helper method thunar_dialogs_show_help(), which is used to open the documentation browser. * thunar/thunar-window-ui.xml, thunar/thunar-window.c: Add "Contents" item to the "Help" menu. * thunar/thunar-chooser-button.c(thunar_chooser_button_file_changed): Fix typo. * po/Thunar.pot, po/*.po: Merge new strings. * po/de.po: Updated the german translations. (Old svn revision: 20145)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 16d4df93..13bb3b9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,6 +28,16 @@ rpm: dist
rpmbuild -ta $(PACKAGE)-$(VERSION).tar.gz
@rm -f $(PACKAGE)-$(VERSION).tar.gz
+libexec_SCRIPTS = \
+ ThunarHelp
+
+ThunarHelp: ThunarHelp.in Makefile
+ rm -f ThunarHelp.gen ThunarHelp
+ sed -e "s,\@datadir\@,$(datadir),g" \
+ < $(srcdir)/ThunarHelp.in \
+ > ThunarHelp.gen
+ mv ThunarHelp.gen ThunarHelp
+
desktopdir = $(datadir)/applications
desktop_in_files = Thunar.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
@@ -44,6 +54,7 @@ endif
EXTRA_DIST = \
FAQ \
HACKING \
+ ThunarHelp.in \
intltool-extract.in \
intltool-merge.in \
intltool-update.in \
@@ -51,12 +62,13 @@ EXTRA_DIST = \
$(service_in_files)
DISTCLEANFILES = \
+ ThunarHelp \
intltool-extract \
intltool-merge \
intltool-update \
$(desktop_DATA) \
$(service_DATA)
-DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-xsltproc
# vi:set ts=8 sw=8 noet ai nocindent syntax=automake: