summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenedikt Meurer <benny@xfce.org>2005-11-29 17:28:56 +0000
committerBenedikt Meurer <benny@xfce.org>2005-11-29 17:28:56 +0000
commitf1883411d44c4435bc5527fff92201486d0d1d7a (patch)
tree22c78e33c2586f6fc991f1f4f0c51b9f9cc5a9bb /Makefile.am
parentfe6fede9b75018166e66a9a48d35c1196e704e44 (diff)
downloadthunar-f1883411d44c4435bc5527fff92201486d0d1d7a.tar.gz
2005-11-29 Benedikt Meurer <benny@xfce.org>
* thunar/thunar-standard-view.c (thunar_standard_view_merge_custom_actions): Fix typo. * thunarx/thunarx-private.{c,h}, thunarx/thunarx-menu-provider.c, thunarx/Makefile.am, thunarx/thunarx-property-page-provider.c: Add helper function thunarx_object_list_take_reference(), so we don't need to repeat the same code again and again. * thunar/thunar-window.c(action_entries): Add ... to the Preferences action, since it opens a dialog. Use "e" as mnemonic, as "P" is already used by "Paste". * thunar/thunar-standard-view.c(action_entries): Add ... to the Select by Pattern action, since it opens a dialog. * thunar/thunar-preferences-dialog.c: Close preferences dialog on Esc key press. * thunarx/thunarx-preferences-provider.{c,h}, thunarx/thunarx.h, thunarx/thunarx.symbols, thunarx/Makefile.am: Add new interface ThunarxPreferencesProvider, which can be implemented to add custom actions to the preferences section of the "Edit" menu. * thunar/thunar-window-ui.xml, thunar/thunar-window.c: Query custom preferences actions from the installed providers and add them to the preferences section of the "Edit" menu. Actions are loaded in an idle source to not delay folder loading when opening a new window, even if a lot of preferences providers are installed. * docs/reference/thunarx/: Update the thunarx reference documentation. * thunar-uca/, configure.in.in, Makefile.am: Import the thunar-uca module, which provides advanced users with an easy way to add custom actions to Thunar's context menus. With this extension in place there's no longer a need to add support G-Scripts (except maybe an importer for thunar-uca). * po/POTFILES.in: Add new translatable files. * po/: Merge new strings. * examples/tex-open-terminal/README: Add note to use thunar-uca, and consider the tex-open-terminal as example for extension writers. (Old svn revision: 18962)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 11a07a0b..6df42481 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,16 +1,21 @@
# $Id$
+if ENABLE_UCA_PLUGIN
+SUBDIRS_THUNAR_UCA = thunar-uca
+endif
+
SUBDIRS = \
icons \
pixmaps \
po \
tdb \
- thunar-vfs \
thunarx \
+ thunar-vfs \
thunar \
tests \
docs \
- examples
+ examples \
+ $(SUBDIRS_THUNAR_UCA)
AUTOMAKE_OPTIONS = \
1.8 \