summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Schermer <nick@xfce.org>2010-06-01 17:30:43 +0200
committerNick Schermer <nick@xfce.org>2010-06-01 17:30:43 +0200
commitd807633ec7610b413aad3de846308e99f360efbd (patch)
tree08a5e407fba27032d3662adb944870c4a864b1c5 /Makefile.am
parent6017c4bdccfa1acce9c1cc4685479db909279ea8 (diff)
downloadthunar-d807633ec7610b413aad3de846308e99f360efbd.tar.gz
Build ChangeLog from GIT.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 18e2c9cb..dce959ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,15 @@ rpm: dist
rpmbuild -ta $(PACKAGE)-$(VERSION).tar.gz
@rm -f $(PACKAGE)-$(VERSION).tar.gz
+.PHONY: ChangeLog
+
+ChangeLog: Makefile
+ (GIT_DIR=$(top_srcdir)/.git git log > .changelog.tmp \
+ && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) \
+ || (touch ChangeLog; echo 'Git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+
libexec_SCRIPTS = \
ThunarBulkRename \
ThunarHelp