summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Schermer <nick@xfce.org>2010-08-26 20:06:12 +0200
committerNick Schermer <nick@xfce.org>2010-08-26 20:15:41 +0200
commitbe47687faab010299fc926b97599d114a909787f (patch)
tree770d9ac199173995965e233fdd4b6a0b3dfd7ae6 /Makefile.am
parent3826f7e5f812879251231724784c5d27f8c91a2a (diff)
downloadthunar-be47687faab010299fc926b97599d114a909787f.tar.gz
Move helpers from $libexecdir to $libdir/Thunar.
FHS 2.3 forbids files in $libexecdir, so install the files in $libdir.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 85226d5c..356e6338 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,7 +45,8 @@ ChangeLog: Makefile
dist-hook: ChangeLog
-libexec_SCRIPTS = \
+thunar_scriptsdir = $(libdir)/Thunar
+thunar_scripts_SCRIPTS = \
ThunarBulkRename \
ThunarHelp
@@ -74,7 +75,7 @@ desktop_in_in_files = \
Thunar-folder-handler.desktop.in.in
desktop_in_files = $(desktop_in_in_files:.desktop.in.in=.desktop.in)
%.desktop.in: %.desktop.in.in
- $(AM_V_GEN) sed -e "s,\@libexecdir\@,$(libexecdir),g" < $< > $@
+ $(AM_V_GEN) sed -e "s,\@libdir\@,$(libdir),g" < $< > $@
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@