summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenedikt Meurer <benny@xfce.org>2006-02-07 21:41:50 +0000
committerBenedikt Meurer <benny@xfce.org>2006-02-07 21:41:50 +0000
commitbbb7233fbb48e78d7e26a80927d3d40192848c71 (patch)
tree7de703c2b1664f04e21a9dee4f44e14006a698e3 /Makefile.am
parent226bc36f152bec67f79a1f00103c045f643d6d45 (diff)
downloadthunar-bbb7233fbb48e78d7e26a80927d3d40192848c71.tar.gz
2006-02-07 Benedikt Meurer <benny@xfce.org>
* thunar/thunar-application.{c,h}: Add thunar_application_take_window(), which is used to add a GtkWindow to the internal application windows list. The application will not exit until the last controlled window is closed by the user. * thunar/thunar-file.{c,h}: Use a generic parent parameter for the thunar_file_launch() method. * thunar/thunar-chooser-dialog.{c,h}: Use a generic parent paramter for the thunar_show_chooser_dialog() method, and let the application take over control of the dialog window. * thunar/thunar-gdk-extensions.{c,h}, thunar/Makefile.am: Import method thunar_gdk_screen_open() from Terminal, which opens a GdkScreen from a full qualified display name. * README, configure.in.in: Add optional check for D-BUS. * thunar/Makefile.am, org.xfce.FileManager.service.in, Makefile.am, thunar/thunar-dbus-service-infos.xml, thunar/thunar-application.{c,h}, thunar/thunar-dbus-service.{c,h}: Initial import of the basic D-BUS service for Thunar, the org.xfce.FileManager implementation. See the thunar-dbus-service-infos.xml file for a description of the current interface. * po/Thunar.pot, po/*.po: Update the translations. (Old svn revision: 19776)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6df42481..75c8fc25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,19 +33,29 @@ desktop_in_files = Thunar.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
+if HAVE_DBUS
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.xfce.FileManager.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+%.service: %.service.in
+ sed -e "s,\@bindir\@,$(bindir),g" < $< > $@
+endif
+
EXTRA_DIST = \
FAQ \
HACKING \
intltool-extract.in \
intltool-merge.in \
intltool-update.in \
- $(desktop_in_files)
+ $(desktop_in_files) \
+ $(service_in_files)
DISTCLEANFILES = \
intltool-extract \
intltool-merge \
intltool-update \
- $(desktop_DATA)
+ $(desktop_DATA) \
+ $(service_DATA)
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc