summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenedikt Meurer <benny@xfce.org>2006-03-24 01:50:07 +0000
committerBenedikt Meurer <benny@xfce.org>2006-03-24 01:50:07 +0000
commita5c28c6c095fe5c1d551ec6a1abf414fddc810a6 (patch)
tree9e21d1e1fc14e00ac22f703b5a5a7603b2cc719e /Makefile.am
parent447b6a56793533d6c74c7938e32f3ff8f80ea948 (diff)
downloadthunar-a5c28c6c095fe5c1d551ec6a1abf414fddc810a6.tar.gz
2006-03-24 Benedikt Meurer <benny@xfce.org>
* thunar/thunar-file.{c,h}: Add wrapper method thunar_file_get_for_uri() which is a rather common operation. * thunar/thunar-dbus-service.c (thunar_dbus_service_parse_uri_and_display): Use the newly added method thunar_file_get_for_uri(). * thunar/thunar-launcher.c: If no current directory is set, directories will always be opened in new windows. * thunar/thunar-renamer-progress.{c,h}: Add support for explicit cancellation of the rename operation. * thunar/thunar-renamer-dialog-ui.xml,thunar/thunar-renamer-model.{c,h}, thunar/thunar-renamer-dialog.{c,h}, thunar/Makefile.am: Some polish on the dialog and the model. Allow users to add/remove files using the context menu. Add a standalone mode in which the bulk rename dialog appears as standalone application and which can be invoked through the D-BUS service. Bug #1597. * thunar/thunar-standard-view.c(thunar_standard_view_action_rename): Keep up with the ThunarRenamerDialog changes. * thunar/main.c, thunar/thunar-application.{c,h}, thunar/thunar-dbus-client.{c,h}, thunar/thunar-dbus-service-infos.xml, thunar/thunar-dbus-service.c: Add BulkRename() method to the D-BUS interface org.xfce.Thunar and add command line option -B to Thunar, which allows to open the bulk rename dialog directly. Bug #1597. * Thunar-folder-handler.desktop.in.in, Thunar.desktop.in.in, Makefile.am: Rearrange the .desktop file handling. * Makefile.am, Thunar-bulk-rename.desktop.in.in, ThunarBulkRename.in: Add launcher for the bulk rename utility. Bug #1597. * examples/thunar-file-manager.py, examples/Makefile.am: Add example for the usage of the org.xfce.Thunar interface. * thunarx/thunarx-renamer.{c,h}, thunarx/thunarx.symbols: Add new method get_actions() to ThunarxRenamer, as discussed with Jannis, to allow plugin writers to add custom actions to the renamers tree view context menu (i.e. "Edit Tags" for the thunar-media-tag-plugin). First part of bug #1602. * docs/reference/thunarx/: Update the API docs. * thunar/thunar-renamer-dialog.c(thunar_renamer_dialog_context_menu), thunar/thunar-renamer-dialog-ui.xml: Add custom actions provided by the active ThunarxRenamer to the file context menu in the renamer dialog. Second part of bug #1602. * po/POTFILES.in: Add new files. * po/Thunar.pot, po/*.po: Merge new strings. * po/de.po: Update german translations. (Old svn revision: 20526)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d494ecd..ee084240 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,8 +26,16 @@ rpm: dist
@rm -f $(PACKAGE)-$(VERSION).tar.gz
libexec_SCRIPTS = \
+ ThunarBulkRename \
ThunarHelp
+ThunarBulkRename: ThunarBulkRename.in Makefile
+ rm -f ThunarBulkRename.gen ThunarBulkRename
+ sed -e "s,\@bindir\@,$(bindir),g" \
+ < $(srcdir)/ThunarBulkRename.in \
+ > ThunarBulkRename.gen
+ mv ThunarBulkRename.gen ThunarBulkRename
+
ThunarHelp: ThunarHelp.in Makefile
rm -f ThunarHelp.gen ThunarHelp
sed -e "s,\@datadir\@,$(datadir),g" \
@@ -36,7 +44,13 @@ ThunarHelp: ThunarHelp.in Makefile
mv ThunarHelp.gen ThunarHelp
desktopdir = $(datadir)/applications
-desktop_in_files = Thunar.desktop.in Thunar-folder-handler.desktop.in
+desktop_in_in_files = \
+ Thunar.desktop.in.in \
+ Thunar-bulk-rename.desktop.in.in \
+ Thunar-folder-handler.desktop.in.in
+desktop_in_files = $(desktop_in_in_files:.desktop.in.in=.desktop.in)
+%.desktop.in: %.desktop.in.in
+ sed -e "s,\@libexecdir\@,$(libexecdir),g" < $< > $@
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
@@ -51,18 +65,21 @@ endif
EXTRA_DIST = \
FAQ \
HACKING \
+ ThunarBulkRename.in \
ThunarHelp.in \
intltool-extract.in \
intltool-merge.in \
intltool-update.in \
- $(desktop_in_files) \
+ $(desktop_in_in_files) \
$(service_in_files)
DISTCLEANFILES = \
+ ThunarBulkRename \
ThunarHelp \
intltool-extract \
intltool-merge \
intltool-update \
+ $(desktop_in_files) \
$(desktop_DATA) \
$(service_DATA)