summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Koegel <eric.koegel@gmail.com>2014-09-26 19:20:11 +0300
committerSimon Steinbeiss <simon.steinbeiss@elfenbeinturm.at>2014-11-01 19:56:30 +0100
commit9e3a5dccfa01e096b0905020fa3ef4453b976ced (patch)
treee6a81ccf713649c182681c80909d37d22fd70de8 /Makefile.am
parent4038bde80f2311fd888f6cb807b0f7eeb574a855 (diff)
downloadthunar-9e3a5dccfa01e096b0905020fa3ef4453b976ced.tar.gz
Add appdata file for Thunar (Bug 11172)
Ryan Lerch wrote most of the appdata file, I only added the url help and the autoconf stuff to use intltool for translated strings in the appdata as we can do that as upstream. See: http://www.freedesktop.org/software/appstream/docs/sect-Metadata-Application.html Signed-off-by: Simon Steinbeiss <simon.steinbeiss@elfenbeinturm.at>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ece3b410..3c561270 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,14 @@ desktop_in_files = $(desktop_in_in_files:.desktop.in.in=.desktop.in)
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
+#
+# .appdata
+#
+@INTLTOOL_XML_RULE@
+appdatadir = $(datadir)/appdata
+appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+appdata_in_files = thunar.appdata.xml.in
+
if HAVE_DBUS
servicedir = $(datadir)/dbus-1/services
service_in_files = org.xfce.FileManager.service.in org.xfce.Thunar.service.in
@@ -82,7 +90,10 @@ EXTRA_DIST = \
intltool-merge.in \
intltool-update.in \
$(desktop_in_in_files) \
- $(service_in_files)
+ $(service_in_files) \
+ $(appdata_in_files)
+
+CLEANFILES = $(appdata_DATA)
DISTCLEANFILES = \
ThunarBulkRename \