summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenedikt Meurer <benny@xfce.org>2006-02-08 22:58:40 +0000
committerBenedikt Meurer <benny@xfce.org>2006-02-08 22:58:40 +0000
commit736ae7a33778f623e3f1d465435a8973aa298ef5 (patch)
treeee6628adf452511ed1b08e28c133e37f687c5bda /Makefile.am
parentcbeec7da85e51bd3f10257d2c6415330af507342 (diff)
downloadthunar-736ae7a33778f623e3f1d465435a8973aa298ef5.tar.gz
2006-02-08 Benedikt Meurer <benny@xfce.org>
* thunar-vfs/thunar-vfs-util.{c,h}, thunar-vfs/thunar-vfs.symbols: Add new function thunar_vfs_canonicalize_filename(). * thunar-vfs/thunar-vfs-path.c(thunar_vfs_path_new): Use thunar_vfs_canonicalize_filename() on absolute paths. * docs/reference/thunar-vfs/: Update the thunar-vfs API docs. * thunar/thunar-dialogs.{c,h}: Use a generic parent parameter instead of a GtkWidget, so this method is also usable if no GtkWidget is none, but the dialog must appear on a specific screen. * thunar/thunar-application.{c,h}: Add a "daemon" property, which determines whether Thunar will exit once the last window is closed. Remove the D-BUS service here. Add process_filenames() method, to process the list of filenames given on the command line. Bug #1384. * thunar/main.c: Attach the D-BUS here. * Makefile.am, org.xfce.Thunar.service.in: Add Thunar specific service file. * thunar/thunar-dbus-service-infos.xml, thunar/thunar-dbus-service.c: Add the org.xfce.Thunar interface here, with currently only a LaunchFiles() method, which can process Thunar command line parameters in a remote instance. Bug #1384. * thunar/thunar-dbus-client.{c,h}, thunar/Makefile.am: Add convenience wrapper for the D-BUS LaunchFiles() of the org.xfce.Thunar interface, which is used on startup to first try to reuse an existing instance. This way new folder windows will popup instantly if an instance of Thunar is already running. * org.xfce.Thunar.service.in, org.xfce.FileManager.service.in, thunar/main.c: Add --daemon option and use it when starting from the message bus. Pass all additional parameters as file names to a run- ning remote instance or to ThunarApplication as fallback. Bug #1384. * examples/xfce-file-manager.py, examples/Makefile.am: Add a simple example how to communicate with the file manager using the D-BUS Python bindings. * po/Thunar.pot, po/*.po: Merge new strings. (Old svn revision: 19782)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 75c8fc25..16d4df93 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,7 +35,7 @@ desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
if HAVE_DBUS
servicedir = $(datadir)/dbus-1/services
-service_in_files = org.xfce.FileManager.service.in
+service_in_files = org.xfce.FileManager.service.in org.xfce.Thunar.service.in
service_DATA = $(service_in_files:.service.in=.service)
%.service: %.service.in
sed -e "s,\@bindir\@,$(bindir),g" < $< > $@