summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis@xfce.org>2010-07-21 13:41:29 +0200
committerJannis Pohlmann <jannis@xfce.org>2010-07-25 19:42:29 +0200
commit344b273424f3e49fdedeb677db48db8fdaebf67c (patch)
treee6437509743651e195e3138f1f8e557ed3768d2d /Makefile.am
parent11b47a673e22f3b9e7715548b5f5ca1a8ee8ba2a (diff)
downloadthunar-volman-344b273424f3e49fdedeb677db48db8fdaebf67c.tar.gz
Initial work on porting thunar-volman-settings to the new code.
The storage devices tab already works again.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 4 insertions, 26 deletions
diff --git a/Makefile.am b/Makefile.am
index 47b4284..14481ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,8 @@
SUBDIRS = \
icons \
po \
- thunar-volman
+ thunar-volman \
+ thunar-volman-settings
distclean-local:
rm -rf *.spec *.cache *~
@@ -12,38 +13,15 @@ rpm: dist
rpmbuild -ta $(PACKAGE)-$(VERSION).tar.gz
@rm -f $(PACKAGE)-$(VERSION).tar.gz
-libexec_SCRIPTS = \
- thunar-volman-settings
-
-thunar-volman-settings: thunar-volman-settings.in Makefile
- rm -f thunar-volman-settings.gen thunar-volman-settings
- sed -e "s,\@bindir\@,$(bindir),g" \
- < $(srcdir)/thunar-volman-settings.in \
- > thunar-volman-settings.gen
- mv thunar-volman-settings.gen thunar-volman-settings
-
-desktopdir = $(datadir)/applications
-desktop_in_in_files = thunar-volman-settings.desktop.in.in
-desktop_in_files = $(desktop_in_in_files:.desktop.in.in=.desktop.in)
-%.desktop.in: %.desktop.in.in
- sed -e "s,\@libexecdir\@,$(libexecdir),g" < $< > $@
-desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
-
EXTRA_DIST = \
THANKS \
intltool-extract.in \
intltool-merge.in \
- intltool-update.in \
- thunar-volman-settings.in \
- $(desktop_in_in_files)
+ intltool-update.in
DISTCLEANFILES = \
intltool-extract \
intltool-merge \
- intltool-update \
- thunar-volman-settings \
- $(desktop_in_files) \
- $(desktop_DATA)
+ intltool-update
# vi:set ts=8 sw=8 noet ai nocindent syntax=automake: