summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..7b3f0ab8
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,37 @@
+SUBDIRS = src data po doc
+
+EXTRA_DIST = \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in
+
+DISTCLEANFILES = \
+ intltool-extract \
+ intltool-merge \
+ intltool-update
+
+distclean-local:
+ rm -rf *.cache
+
+rpm: dist
+ rpmbuild -ta $(PACKAGE)-$(VERSION).tar.gz
+ @rm -f $(PACKAGE)-$(VERSION).tar.gz
+
+html: Makefile
+ make -C doc html
+
+dist-bz2: dist
+ zcat $(PACKAGE)-$(VERSION).tar.gz | \
+ bzip2 --best -c > $(PACKAGE)-$(VERSION).tar.bz2
+
+distcheck-bz2: distcheck
+ zcat $(PACKAGE)-$(VERSION).tar.gz | \
+ bzip2 --best -c > $(PACKAGE)-$(VERSION).tar.bz2
+
+snapshot: dist
+ mv $(PACKAGE)-$(VERSION).tar.gz \
+ $(PACKAGE)-$(VERSION)-r@REVISION@.tar.gz
+
+snapshot-bz2: dist-bz2
+ mv $(PACKAGE)-$(VERSION).tar.bz2 \
+ $(PACKAGE)-$(VERSION)-r@REVISION@.tar.bz2 \ No newline at end of file