summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 66c3ea3..4c51c0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -238,6 +238,14 @@ if test x$have_libelf != xyes; then
AC_MSG_ERROR([libelf not found])
fi
+AC_ARG_WITH(system-install-dir,
+ [AS_HELP_STRING([--with-system-install-dir=DIR],
+ [Location of system installation [LOCALSTATEDIR/lib/flatpak]])],
+ [],
+ [with_system_install_dir='$(localstatedir)/lib/flatpak'])
+SYSTEM_INSTALL_DIR=$with_system_install_dir
+AC_SUBST(SYSTEM_INSTALL_DIR)
+
dnl This only checks for the header, not the library.
AC_ARG_WITH([dwarf-header],
[AS_HELP_STRING([--with-dwarf-header],