summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Thibault <sthibault@debian.org>2009-08-20 09:54:45 +0200
committerJulien Danjou <julien@danjou.info>2009-08-20 09:54:45 +0200
commit3d8dfe9a9ad0a22bdcec555bd3d0d9b5950a6dab (patch)
treed241894d05e20db502e7901e7c9f0d31bca35903 /configure.ac
parentef2431f5bdef1da9f2f7701232def164910b191b (diff)
downloadxcb-pthread-stubs-3d8dfe9a9ad0a22bdcec555bd3d0d9b5950a6dab.tar.gz
Provide sem_* functions
Some applications, instead of using pthread_mutex_t, use anonymous semaphores (sem_init) for locking. Signed-off-by: Julien Danjou <julien@danjou.info>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b7f0698..ffccea9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,7 @@ fi
PKG_CONFIG_LIBS=
-AC_CHECK_FUNCS([pthread_self pthread_mutex_init pthread_mutex_destroy pthread_mutex_lock pthread_mutex_unlock pthread_cond_init pthread_cond_destroy pthread_cond_wait pthread_cond_signal pthread_cond_broadcast pthread_equal],
+AC_CHECK_FUNCS([pthread_self pthread_mutex_init pthread_mutex_destroy pthread_mutex_lock pthread_mutex_unlock pthread_cond_init pthread_cond_destroy pthread_cond_wait pthread_cond_signal pthread_cond_broadcast pthread_equal sem_init sem_destroy sem_wait sem_trywait],
[], [PKG_CONFIG_LIBS='-L${libdir} -lpthread-stubs'])
AC_SUBST([PKG_CONFIG_LIBS])
AM_CONDITIONAL(BUILD_LIB, test "x$PKG_CONFIG_LIBS" != x)