summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2017-02-20 11:18:58 +0000
committerUli Schlachter <psychon@znc.in>2017-03-01 17:42:40 +0100
commit8340ebd656c7e1a5b6d31170c1f3c87df043e793 (patch)
tree0da84379a074c2e047c9c7cf2ea3c8331223d6a6 /Makefile.am
parent816ca2affbd5a9d2e551851de4d0a26ec080d948 (diff)
downloadxcb-pthread-stubs-8340ebd656c7e1a5b6d31170c1f3c87df043e793.tar.gz
Rework the pthread-stub design
The current design handles the most common use-cases, although it causes breakage on others (when a pthreads liked library is dlopened). Refer to the README for further details. The new design, makes pthread-stubs a "meta" package which _never_ provides a library but only a .pc file. pthread-stubs checks if the run-time (libc or otherwise) expose lightweight pthread symbols to link against and defaults to a full blown pthread. This way projects can use the Cflags/Libs without having to know the details. Alternatively they can directly link against the pthread implementation, although that might bring unwarranted overhead. v2: - Remove m4 macro, always use -pthread and document why. - Sort the symbol list, document how it's derived what is allowed and what not. - Rework the README to start from current state of afairs to past ones. - Document platforms that are 'safe' and ones that are not. v3: - Add SVN note about -pthread + Cygwin/mingw/mingw-w64 Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Acked-by: Eric Anholt <eric@anholt.net> Signed-off-by: Uli Schlachter <psychon@znc.in>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 0 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 2329572..93123a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,12 +1,2 @@
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = pthread-stubs.pc
-
-if BUILD_LIB
-stubs.c: list.m4 stubs.c.m4
- m4 -P -I $(srcdir) stubs.c.m4 > $@
-
-lib_LTLIBRARIES = libpthread-stubs.la
-nodist_libpthread_stubs_la_SOURCES = stubs.c
-CLEANFILES = stubs.c
-endif
-EXTRA_libpthread_stubs_la_SOURCES = stubs.c.m4