summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2006-03-04 18:29:40 -0800
committerJosh Triplett <josh@freedesktop.org>2006-03-04 18:29:40 -0800
commit66f5611130625d2db2c5106e387ce2fb5b3fc28c (patch)
treebd31a4d1df55e74bff35f05b672c24f8f9ae5f9d /configure.ac
parent3084d8b32e541c7a4f8e198be2566bc6d6f4aa98 (diff)
downloadxcb-proto-66f5611130625d2db2c5106e387ce2fb5b3fc28c.tar.gz
Validate protocol descriptions against schema in "make check", using xmllint. These tests will also run when doing "make distcheck" to create a distribution.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2baaab4..5b52e6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,12 @@ AC_INIT([XCBProto],
AC_CONFIG_SRCDIR([xcb-proto.pc.in])
AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AC_PATH_PROG(XMLLINT, xmllint, no)
+AM_CONDITIONAL(HAVE_XMLLINT, test "x$XMLLINT" != "xno")
+if test "$XSLTPROC" = "no"; then
+ AC_MSG_WARN([xmllint not found; unable to validate against schema.])
+fi
+
xcbincludedir='${includedir}/X11/XCB'
AC_SUBST(xcbincludedir)