summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2014-02-12 14:15:45 -0800
committerUli Schlachter <psychon@znc.in>2014-03-22 14:44:52 +0100
commit32de4c4213a49c61127c6957ea05fef3e5355291 (patch)
tree2c802732e826ea7018a7262e0c138db07b21903d /Makefile.am
parent1f6cd9f1fcd3c07d323b678292c9cb00ae1f7504 (diff)
downloadxcb-libxcb-32de4c4213a49c61127c6957ea05fef3e5355291.tar.gz
Validate .pc file Requires lines
This walks through the .pc.in files and makes sure all of the Requires lines express sufficient dependency information. Signed-off-by: Keith Packard <keithp@keithp.com> Signed-off-by: Uli Schlachter <psychon@znc.in>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 387c2f2..e912489 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -86,8 +86,14 @@ pkgconfig_DATA += xcb-xvmc.pc
endif
+AM_TESTS_ENVIRONMENT = \
+ AM_SRCDIR=${srcdir}
+
+TESTS=check-pc-requires
+
EXTRA_DIST = \
tools/README \
tools/api_conv.pl \
tools/constants \
-autogen.sh
+autogen.sh \
+$(TESTS)