summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-09-22 11:23:51 +0100
committerWill Thompson <will.thompson@collabora.co.uk>2010-02-24 18:47:33 +0000
commitf44b14786d2d55886896182967a796c1b5155156 (patch)
treed8b80f0fd81ba78362ecde006e06e6d0100b6ac0 /tests/Makefile.am
parent8ea80a23dda679d8d4511762974b9d8af7d5b90b (diff)
downloadwocky-f44b14786d2d55886896182967a796c1b5155156.tar.gz
add wocky-pubsub-service-test.c
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 88220dd..5e51a6f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -68,6 +68,7 @@ TEST_PROGS = wocky-xmpp-reader-test \
wocky-pep-service-test \
wocky-tls-test \
wocky-data-forms-test \
+ wocky-pubsub-service-test \
wocky-connector-test
wocky_tls_test_DEPENDENCIES = $(LIBWOCKY)
@@ -187,6 +188,12 @@ wocky_data_forms_test_SOURCES = \
wocky-test-stream.c wocky-test-stream.h \
wocky-data-forms-test.c
+wocky_pubsub_service_test_DEPENDENCIES = $(LIBWOCKY)
+wocky_pubsub_service_test_SOURCES = \
+ wocky-test-helper.c wocky-test-helper.h \
+ wocky-test-stream.c wocky-test-stream.h \
+ wocky-pubsub-service-test.c
+
AM_CFLAGS = $(ERROR_CFLAGS) $(GCOV_CFLAGS) @GLIB_CFLAGS@ @LIBXML2_CFLAGS@ @TLS_CFLAGS@ @WOCKY_CFLAGS@
AM_LDFLAGS = $(GCOV_LIBS) @GLIB_LIBS@ @LIBXML2_LIBS@ @TLS_LIBS@
LDADD = $(top_builddir)/wocky/libwocky.la