summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-09-25 14:56:17 +0100
committerWill Thompson <will.thompson@collabora.co.uk>2010-02-22 14:21:07 +0000
commit93cca1c0b5797487c512ea6c7987d4d3978bf768 (patch)
treefd5f88b9be009892f60ce2b86b1fff1ac3fc4661 /tests/Makefile.am
parenta00881f8d5ae67fef9230985bb44115b1447e272 (diff)
downloadwocky-93cca1c0b5797487c512ea6c7987d4d3978bf768.tar.gz
add wocky-data-forms-test.c
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f146e96..88220dd 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -67,6 +67,7 @@ TEST_PROGS = wocky-xmpp-reader-test \
wocky-session-test \
wocky-pep-service-test \
wocky-tls-test \
+ wocky-data-forms-test \
wocky-connector-test
wocky_tls_test_DEPENDENCIES = $(LIBWOCKY)
@@ -180,9 +181,14 @@ wocky_pep_service_test_SOURCES = \
wocky-test-stream.c wocky-test-stream.h \
wocky-pep-service-test.c
+wocky_data_forms_test_DEPENDENCIES = $(LIBWOCKY)
+wocky_data_forms_test_SOURCES = \
+ wocky-test-helper.c wocky-test-helper.h \
+ wocky-test-stream.c wocky-test-stream.h \
+ wocky-data-forms-test.c
+
AM_CFLAGS = $(ERROR_CFLAGS) $(GCOV_CFLAGS) @GLIB_CFLAGS@ @LIBXML2_CFLAGS@ @TLS_CFLAGS@ @WOCKY_CFLAGS@
AM_LDFLAGS = $(GCOV_LIBS) @GLIB_LIBS@ @LIBXML2_LIBS@ @TLS_LIBS@
-
LDADD = $(top_builddir)/wocky/libwocky.la
check_PROGRAMS = $(TEST_PROGS)