summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2011-12-14 12:28:36 +0100
committerXavier Claessens <xclaesse@gmail.com>2011-12-14 13:32:13 +0100
commit244dd4e32315ba79d2ff340e7a87a4be3b9dd5e8 (patch)
tree76af7ed9079a7bcb5fbfc0a7c7e45a928ab4f931 /tests/Makefile.am
parent85556079abd82cc6d86a395e5b3e9e35da1482a8 (diff)
downloadwocky-244dd4e32315ba79d2ff340e7a87a4be3b9dd5e8.tar.gz
Add tests/wocky-dummy-xmpp-server.c to build system and fix it
Code that we don't build won't build.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c2d5c0a..7be6c8f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -64,6 +64,8 @@ TEST_PROGS = wocky-xmpp-reader-test \
wocky-scram-sha1-test \
wocky-caps-hash-test
+noinst_PROGRAMS=
+
wocky_tls_test_DEPENDENCIES = $(LIBWOCKY)
wocky_tls_test_SOURCES = \
wocky-tls-test.c \
@@ -235,6 +237,17 @@ wocky_http_proxy_test_SOURCES = wocky-http-proxy-test.c \
wocky-test-helper.c wocky-test-helper.h \
wocky-test-stream.c wocky-test-stream.h
+wocky_dummy_xmpp_server_DEPENDENCIES = $(LIBWOCKY)
+wocky_dummy_xmpp_server_SOURCES = wocky-dummy-xmpp-server.c \
+ wocky-test-connector-server.c wocky-test-connector-server.h \
+ wocky-test-sasl-auth-server.c wocky-test-sasl-auth-server.h
+wocky_dummy_xmpp_server_LDADD = $(LDADD) @LIBSASL2_LIBS@
+wocky_dummy_xmpp_server_CFLAGS = $(AM_CFLAGS) @LIBSASL2_CFLAGS@ $(TLSDEFS)
+
+if HAVE_LIBSASL2
+ noinst_PROGRAMS += wocky-dummy-xmpp-server
+endif
+
wocky_caps_hash_test_DEPENDENCIES = $(LIBWOCKY)
wocky_caps_hash_test_SOURCES = wocky-caps-hash-test.c \
wocky-test-helper.c wocky-test-helper.h \