summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rühsen <tim.ruehsen@gmx.de>2019-02-19 15:10:59 +0100
committerTim Rühsen <tim.ruehsen@gmx.de>2019-02-19 15:11:04 +0100
commit1098de2b49f8889ff5e2446f88ae3b3563d9dbc1 (patch)
tree34907ea4f240698a1de3d5b3fb129b973813bf69 /configure.ac
parentc7f31d62b28eff2944f74eba195fc31f1e44dfe7 (diff)
downloadwget-1098de2b49f8889ff5e2446f88ae3b3563d9dbc1.tar.gz
Do not hard-code -ldl in fuzz/Makefile.am
* configure.ac: Search for dlopen and add library to $FUZZ_LIBS * fuzz/Makefile.am: Link with $FUZZ_LIBS instead of -ldl This fixes linking on BSD systems. Reported-by: Nam Nguyen
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e64e3798..88fbb586 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,6 +103,15 @@ AC_ARG_ENABLE([fuzzing],
#AC_SUBST([FUZZ_LIBS])
AM_CONDITIONAL([FUZZING], [test "$enable_fuzzing" = "yes"])
+dnl needed for some fuzzers
+OLD_LIBS="$LIBS"
+AC_SEARCH_LIBS([dlopen], [dl dld])
+if [[ "${ac_cv_search_dlopen#-l}" != "${ac_cv_search_dlopen}" ]]; then
+ FUZZ_LIBS="${ac_cv_search_dlopen}"
+ AC_SUBST([FUZZ_LIBS])
+fi
+LIBS="$OLD_LIBS"
+
dnl Opie: Support for opie s/key FTP logins
AC_ARG_ENABLE([opie],
[AS_HELP_STRING([--disable-opie], [disable support for opie or s/key FTP login])],