summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index bba80500..24a9de22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -342,19 +342,19 @@ if test x$enable_simple_egl_clients = xyes; then
[egl glesv2 wayland-client wayland-egl wayland-cursor])
fi
-AC_ARG_ENABLE(simple-intel-dmabuf-client,
- AS_HELP_STRING([--disable-simple-intel-dmabuf-client],
- [do not build the simple intel dmabuf client]),,
- enable_simple_intel_dmabuf_client="auto")
-if ! test "x$enable_simple_intel_dmabuf_client" = "xno"; then
- PKG_CHECK_MODULES(SIMPLE_DMABUF_CLIENT, [wayland-client libdrm libdrm_intel],
- have_simple_dmabuf_client=yes, have_simple_dmabuf_client=no)
- if test "x$have_simple_dmabuf_client" = "xno" -a "x$enable_simple_intel_dmabuf_client" = "xyes"; then
+AC_ARG_ENABLE(simple-dmabuf-intel-client,
+ AS_HELP_STRING([--disable-simple-dmabuf-intel-client],
+ [do not build the simple dmabuf intel client]),,
+ enable_simple_dmabuf_intel_client="auto")
+if ! test "x$enable_simple_dmabuf_intel_client" = "xno"; then
+ PKG_CHECK_MODULES(SIMPLE_DMABUF_INTEL_CLIENT, [wayland-client libdrm libdrm_intel],
+ have_simple_dmabuf_intel_client=yes, have_simple_dmabuf_intel_client=no)
+ if test "x$have_simple_dmabuf_intel_client" = "xno" -a "x$enable_simple_dmabuf_intel_client" = "xyes"; then
AC_MSG_ERROR([Intel dmabuf client explicitly enabled, but libdrm_intel couldn't be found])
fi
- enable_simple_intel_dmabuf_client="$have_simple_dmabuf_client"
+ enable_simple_dmabuf_intel_client="$have_simple_dmabuf_intel_client"
fi
-AM_CONDITIONAL(BUILD_SIMPLE_INTEL_DMABUF_CLIENT, test "x$enable_simple_intel_dmabuf_client" = "xyes")
+AM_CONDITIONAL(BUILD_SIMPLE_DMABUF_INTEL_CLIENT, test "x$enable_simple_dmabuf_intel_client" = "xyes")
AC_ARG_ENABLE(clients, [ --enable-clients],, enable_clients=yes)
AM_CONDITIONAL(BUILD_CLIENTS, test x$enable_clients = xyes)