summaryrefslogtreecommitdiff
path: root/kiosk-shell/meson.build
diff options
context:
space:
mode:
authorAlexandros Frantzis <alexandros.frantzis@collabora.com>2020-04-21 18:23:37 +0300
committerPekka Paalanen <pq@iki.fi>2020-07-30 14:38:49 +0000
commit87c1679a0a4c6de48a9f87b6b17bf4df63de1e6b (patch)
tree5e41d8be020d10262098b34668e7bb204bf9963e /kiosk-shell/meson.build
parentea4d13b3e30a599c4cbfec6a0c57f5e952ad25ac (diff)
downloadweston-87c1679a0a4c6de48a9f87b6b17bf4df63de1e6b.tar.gz
kiosk-shell: Introduce kiosk/fullscreen shell for desktop apps
kiosk-shell is fullscreen shell for apps that use the xdg-shell protocol. The goal is to make life easier for people shipping embedded devices with simple fullscreen shell requirements, and reduce the proliferation of desktop-shell hacks. Top level surfaces are made fullscreen, whereas dialogs are placed on top in the center of the output and retain their natural sizes. Dialogs can be moved and (un)maximized, but resizing is currently not supported. An app can be directed to a particular output by populating the "app-ids" field with the app's XDG app id, in the relevant "[output]" section in the weston config file. Fixes: #277 Signed-off-by: Alexandros Frantzis <alexandros.frantzis@collabora.com>
Diffstat (limited to 'kiosk-shell/meson.build')
-rw-r--r--kiosk-shell/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/kiosk-shell/meson.build b/kiosk-shell/meson.build
new file mode 100644
index 00000000..e838614e
--- /dev/null
+++ b/kiosk-shell/meson.build
@@ -0,0 +1,29 @@
+if get_option('shell-kiosk')
+ srcs_shell_kiosk = [
+ 'kiosk-shell.c',
+ 'kiosk-shell-grab.c',
+ 'util.c',
+ weston_desktop_shell_server_protocol_h,
+ weston_desktop_shell_protocol_c,
+ input_method_unstable_v1_server_protocol_h,
+ input_method_unstable_v1_protocol_c,
+ ]
+ deps_shell_kiosk = [
+ dep_libm,
+ dep_libexec_weston,
+ dep_libshared,
+ dep_lib_desktop,
+ dep_libweston_public,
+ ]
+ plugin_shell_kiosk = shared_library(
+ 'kiosk-shell',
+ srcs_shell_kiosk,
+ include_directories: common_inc,
+ dependencies: deps_shell_kiosk,
+ name_prefix: '',
+ install: true,
+ install_dir: dir_module_weston,
+ install_rpath: '$ORIGIN'
+ )
+ env_modmap += 'kiosk-shell.so=@0@;'.format(plugin_shell_kiosk.full_path())
+endif