summaryrefslogtreecommitdiff
path: root/kiosk-shell/meson.build
diff options
context:
space:
mode:
authorDaniel Stone <daniels@collabora.com>2022-02-23 13:24:49 +0000
committerDaniel Stone <daniels@collabora.com>2022-03-31 17:15:55 +0000
commit6cb2526b675be0c7af2840e6bd951fef64486d02 (patch)
treeabe24f82a41cb8498763013003f1cf698a077343 /kiosk-shell/meson.build
parent15a553053a35c68212b9d99927261cc0d7a8c473 (diff)
downloadweston-6cb2526b675be0c7af2840e6bd951fef64486d02.tar.gz
Move shell-utils to its own directory
shell-utils contains a number of helpers which are currently in use by both desktop-shell and kiosk-shell. In order to extend this use to fullscreen-shell as well (which can benefit from reusing the weston_curtain infrastructure to be able to create solid-colour views which may or may not be opaque, as well as one function within fullscreen-shell which was copied wholesale to shell-utils), we need to create a separate Meson dependency object, and avoid the existing pattern of including the source from shared/ within the source list for each shell. This requires creating a new top-level directory for these shared helper functions which are required by each shell, but are not part of libweston in and of itself. shell-utils depends on libweston-desktop; libweston-desktop depends on libweston; libweston depends on shared. Thus it is not possible to expose a dependency object from the shared/ directory which declares a dependency on the libweston-desktop dependency, as Meson processes directories in order and resolves variable references as they are parsed. In order to break this deadlock, this commit creates a new top-level directory called 'shell-utils' containing only this file, which can be parsed by Meson after libweston-desktop (making the libweston-desktop Meson dependency variable available to the build file to declare a dependency on that), but before the shells (making the new Meson depenendency object available to each shell which wishes to use it). This commit contains no functional changes to any observable code. Signed-off-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'kiosk-shell/meson.build')
-rw-r--r--kiosk-shell/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/kiosk-shell/meson.build b/kiosk-shell/meson.build
index c3a37da2..95d94721 100644
--- a/kiosk-shell/meson.build
+++ b/kiosk-shell/meson.build
@@ -2,7 +2,6 @@ if get_option('shell-kiosk')
srcs_shell_kiosk = [
'kiosk-shell.c',
'kiosk-shell-grab.c',
- '../shared/shell-utils.c',
weston_desktop_shell_server_protocol_h,
weston_desktop_shell_protocol_c,
input_method_unstable_v1_server_protocol_h,
@@ -14,6 +13,7 @@ if get_option('shell-kiosk')
dep_libshared,
dep_lib_desktop,
dep_libweston_public,
+ dep_shell_utils,
]
plugin_shell_kiosk = shared_library(
'kiosk-shell',