summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Tretter <m.tretter@pengutronix.de>2018-03-14 10:07:47 +0100
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2018-03-16 12:34:05 +0200
commit824e4995349a84b34aa308db8c923513526a8548 (patch)
tree5338baf8108bac46fb1eee5cdbf3923d91651438 /configure.ac
parent6dba368acc7964d5cb1d14667ba36f3cc4d697af (diff)
downloadweston-824e4995349a84b34aa308db8c923513526a8548.tar.gz
configure.ac: fix have_dbus if dbus support is disabled
If dbus support is explicitly disabled, $have_dbus should be no, but was empty. systemd-login support depends on dbus, but the check does not trigger correctly, if $have_dbus is empty. Signed-off-by: Michael Tretter <m.tretter@pengutronix.de> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0b326ccc..788730cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -502,6 +502,7 @@ AC_ARG_ENABLE(dbus,
AS_HELP_STRING([--disable-dbus],
[do not build with dbus support]),,
enable_dbus=auto)
+have_dbus=no
if test "x$enable_dbus" != "xno"; then
PKG_CHECK_MODULES(DBUS,
dbus-1 >= 1.6,