summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUcan, Emre (ADITG/SW1) <eucan@de.adit-jv.com>2015-11-18 10:23:50 +0000
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-11-27 12:28:37 +0200
commit7d967da8c2034ccbffb091aa84d0f600813b7a0c (patch)
tree209eafa6ff2a6ee8b93fd844a391975b69d64309 /configure.ac
parent062edf2b4c18bba4b46c2b50eda9739cc80e7def (diff)
downloadweston-7d967da8c2034ccbffb091aa84d0f600813b7a0c.tar.gz
configure: don't control egl version
The required version only corresponds to version of mesa implementation. This mesa version requirement causes configure errors, when weston is configured for a different egl implementation than mesa. Because the version of the egl drivers are not alligned to the mesa version. Therefore, I deleted the version controlling for egl, so that weston can be configured for a different egl implementation. Signed-off-by: Emre Ucan <eucan@de.adit-jv.com> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index bcfe9d5b..23b0790e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,8 +85,8 @@ AC_ARG_ENABLE(egl, [ --disable-egl],,
AM_CONDITIONAL(ENABLE_EGL, test x$enable_egl = xyes)
if test x$enable_egl = xyes; then
AC_DEFINE([ENABLE_EGL], [1], [Build Weston with EGL support])
- PKG_CHECK_MODULES(EGL, [egl >= 7.10 glesv2])
- PKG_CHECK_MODULES([EGL_TESTS], [egl >= 7.10 glesv2 wayland-client wayland-egl])
+ PKG_CHECK_MODULES(EGL, [egl glesv2])
+ PKG_CHECK_MODULES([EGL_TESTS], [egl glesv2 wayland-client wayland-egl])
PKG_CHECK_MODULES([GL_RENDERER], [libdrm])
fi
@@ -339,7 +339,7 @@ AC_ARG_ENABLE(simple-egl-clients,
AM_CONDITIONAL(BUILD_SIMPLE_EGL_CLIENTS, test "x$enable_simple_egl_clients" = "xyes")
if test x$enable_simple_egl_clients = xyes; then
PKG_CHECK_MODULES(SIMPLE_EGL_CLIENT,
- [egl >= 7.10 glesv2 wayland-client wayland-egl wayland-cursor])
+ [egl glesv2 wayland-client wayland-egl wayland-cursor])
fi
AC_ARG_ENABLE(simple-intel-dmabuf-client,
@@ -367,7 +367,7 @@ if test x$enable_clients = xyes; then
# Only check for cairo-egl if a GL or GLES renderer requested
AS_IF([test "x$cairo_modules" = "xcairo-gl" -o "x$cairo_modules" = "xcairo-glesv2"], [
- PKG_CHECK_MODULES(CAIRO_EGL, [wayland-egl egl >= 7.10 cairo-egl >= 1.11.3 $cairo_modules],
+ PKG_CHECK_MODULES(CAIRO_EGL, [wayland-egl egl cairo-egl >= 1.11.3 $cairo_modules],
[have_cairo_egl=yes], [have_cairo_egl=no])
AS_IF([test "x$have_cairo_egl" = "xyes"],
[AC_DEFINE([HAVE_CAIRO_EGL], [1], [Have cairo-egl])],