summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Thomas <james.thomas@codethink.co.uk>2014-06-20 12:42:32 +0000
committerJavier Jardón <jjardon@gnome.org>2014-11-25 18:19:35 +0000
commit463b914d4f1efbf5de6d1f45e9037b88a1eb107f (patch)
tree193561c2a9c224bf90675f644c8a7ad4de98b4a1 /configure.ac
parent37052a111a9a023c6e063e2c604b888913ca0632 (diff)
downloadweston-463b914d4f1efbf5de6d1f45e9037b88a1eb107f.tar.gz
compositor-drm: Add support for Tegra Jetson TK1baserock/weston-1.6.0/tegra
Update configure.ac to add check for libdrm_tegra
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 05e883da..67ac0eae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,6 +110,23 @@ fi
PKG_CHECK_MODULES(LIBDRM, [libdrm],
[AC_DEFINE(HAVE_LIBDRM, 1, [Define if libdrm is available]) have_libdrm=yes], have_libdrm=no)
+AC_ARG_ENABLE(libdrm-tegra,
+ AS_HELP_STRING([--disable-libdrm-tegra],
+ [do not build support for nvidia Jetson TK1]),,
+ enable_libdrm_tegra=auto)
+
+if test "x$enable_libdrm_tegra" != "xno"; then
+ PKG_CHECK_MODULES(LIBDRM_TEGRA,
+ libdrm_tegra,
+ have_libdrm_tegra=yes,
+ have_libdrm_tegra=no)
+ if test "x$have_libdrm_tegra" = "xno" -a "x$enable_libdrm_tegra" = "xyes"; then
+ AC_MSG_ERROR([Tegra support explicitly requested, but libdrm_tegra not found])
+ fi
+ AS_IF([test "x$have_libdrm_tegra" = "xyes"],
+ AC_DEFINE([HAVE_DRM_TEGRA], [1], [Enable tegra support in drm backend]))
+fi
+
AC_ARG_ENABLE(x11-compositor, [ --enable-x11-compositor],,
enable_x11_compositor=yes)
AM_CONDITIONAL(ENABLE_X11_COMPOSITOR, test x$enable_x11_compositor = xyes)
@@ -555,4 +572,5 @@ AC_MSG_RESULT([
libwebp Support ${have_webp}
libunwind Support ${have_libunwind}
VA H.264 encoding Support ${have_libva}
+ Tegra DRM Support ${have_libdrm_tegra}
])