summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBryce Harrington <bryce@osg.samsung.com>2015-05-19 13:24:37 -0700
committerBryce Harrington <bryce@osg.samsung.com>2015-05-19 13:24:37 -0700
commit42db3137e1b7914b8e9b3ed5790c1feaee1fb713 (patch)
treed68d31262aa3e367f69dfac311a90403c2755198 /configure.ac
parent6858383d51b12632481370fdc7d886a1e6bb4ebd (diff)
downloadweston-42db3137e1b7914b8e9b3ed5790c1feaee1fb713.tar.gz
configure: Warn that cairo-gl and cairo-glesv2 are risky
Most distros do not ship with gl-enabled cairo, since doing so can result in libgl being linked to each cairo-using client, even if they don't actually use GL, and this can cause much larger per-client memory footprint, and thus can become a resource issue. Furthermore, while in theory this should work fine, we don't actively test this configuration, and there could be random undiscovered bugs if it's used. We keep the option available for people interested in helping us chase down those issues, but warn everyone else away.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5006d592..7d0fa792 100644
--- a/configure.ac
+++ b/configure.ac
@@ -240,9 +240,11 @@ if test "x$with_cairo" = "ximage"; then
else
if test "x$with_cairo" = "xgl"; then
cairo_modules="cairo-gl"
+ AC_MSG_WARN([The --with-cairo=gl option can cause increased resource usage and potential instability, and thus is not recommended. It is needed only for a few special demo programs.])
else
if test "x$with_cairo" = "xglesv2"; then
cairo_modules="cairo-glesv2"
+ AC_MSG_WARN([The --with-cairo=gles2 option can cause increased resource usage and potential instability, and thus is not recommended. It is needed only for a few special demo programs.])
else
AC_ERROR([Unknown cairo renderer requested])
fi