summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFriedrich, Eugen (ADITG/SW1) <efriedrich@de.adit-jv.com>2016-04-05 20:43:29 +0000
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-04-06 14:12:02 +0300
commit265aeb316bce85a9c1941fb6e51b2b7b90760255 (patch)
treef306fb50086422512dc57f11b7f5ce6c5cc50642 /configure.ac
parentd962be149391ac2e00e1197612f2e6ec18dfa9f3 (diff)
downloadweston-265aeb316bce85a9c1941fb6e51b2b7b90760255.tar.gz
systemd: take over sockets created by systemd
Systemd provides a feature of socket-based activation, details in [1] This commit adds an implementation to check if sockets were provided by systemd and adds this as an additional socket to wayland display. before adding sockets are checked for the correctness: only AF_UNIX of type SOCK_STREAM are accepted This is usefull for early rendering use-cases where weston and early-rendering-application can be started parallel. [1] https://www.freedesktop.org/software/systemd/man/systemd.socket.html Signed-off-by: Eugen Friedrich <efriedrich@de.adit-jv.com> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9e8115a7..447cf6b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -634,7 +634,10 @@ AC_ARG_ENABLE(systemd_notify,
AS_HELP_STRING([--enable-systemd-notify],
[Enables systemd notifications to
notify systemd about weston state
- and update watchdog.]),,
+ and update watchdog.
+ Also sockets provided by systemd
+ in case of socket-base activation
+ are added to wayland display]),,
enable_systemd_notify=no)
AM_CONDITIONAL(SYSTEMD_NOTIFY_SUPPORT, test x$enable_systemd_notify = xyes)
if test "x$enable_systemd_notify" = "xyes"; then