summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBryce Harrington <bryce@osg.samsung.com>2014-11-04 16:39:38 -0800
committerBryce Harrington <bryce@osg.samsung.com>2015-05-21 15:06:11 -0700
commitfb9089d4f57bc1c70a4672f802b0858c6a8da0c7 (patch)
tree5458532922b7161473ebe4f7ef89ea96cd2a3b7c /Makefile.am
parent692275f91fe458ac6c858a8d612540d72a1807cc (diff)
downloadweston-fb9089d4f57bc1c70a4672f802b0858c6a8da0c7.tar.gz
tests: Add internal test for the weston test screenshot capability
This also serves as a proof of concept of the screen capture functionality and as a demo for snapshot-based rendering verification. Implements screenshot saving clientside in the test itself. This also demonstrates use of test-specific configuration files, in this case to disable fadein animations and background images. Signed-off-by: Bryce Harrington <bryce@osg.samsung.com> Reviewed-By: Derek Foreman <derekf@osg.samsung.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 543c7369..e860e0e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -941,7 +941,10 @@ libshared_cairo_la_SOURCES = \
# tests subdirectory
#
-TESTS = $(shared_tests) $(module_tests) $(weston_tests) $(ivi_tests)
+TESTS = $(internal_tests) $(shared_tests) $(module_tests) $(weston_tests) $(ivi_tests)
+
+internal_tests = \
+ internal-screenshot.weston
shared_tests = \
config-parser.test \
@@ -988,6 +991,7 @@ noinst_LTLIBRARIES += \
noinst_PROGRAMS += \
$(setbacklight) \
+ $(internal_tests) \
$(shared_tests) \
$(weston_tests) \
$(ivi_tests) \
@@ -1040,6 +1044,20 @@ nodist_libtest_client_la_SOURCES = \
libtest_client_la_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)
libtest_client_la_LIBADD = $(TEST_CLIENT_LIBS) libshared.la libtest-runner.la
+
+#
+# Internal tests - tests functionality of the testsuite itself
+#
+
+internal_screenshot_weston_SOURCES = tests/internal-screenshot-test.c
+internal_screenshot_weston_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS) $(CAIRO_CFLAGS)
+internal_screenshot_weston_LDADD = libtest-client.la $(CAIRO_LIBS)
+
+
+#
+# Weston Tests
+#
+
bad_buffer_weston_SOURCES = tests/bad-buffer-test.c
bad_buffer_weston_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)
bad_buffer_weston_LDADD = libtest-client.la