summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorant8me <ant8me@gmail.com>2018-11-28 22:46:37 +0100
committerDaniel Stone <daniels@collabora.com>2019-02-15 11:18:38 +0000
commitf99fac22ab5c348a5a786b7cf2f48fb8b2dd3435 (patch)
tree44cc6ba06529b8558ca07e4984dd9a819162a113 /Makefile.am
parentd8d9f5e6e16c8f6a3c06763d5f56c27dc9a6e52e (diff)
downloadweston-f99fac22ab5c348a5a786b7cf2f48fb8b2dd3435.tar.gz
clients: use xdg_shell stable instead of v6
Now that Weston supports the stable revision, use it. Better to excercise the current rather than outdated protocol. Pekka: - split the patch, rewrote commit message - rename xdg_shell_ping to xdg_wm_base_ping - rename xdg_shell_listener to wm_base_listener - rename shell to wm_base - fix continued line alignment - drop unrelated change of adding parentheses around bit-wise and Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 14 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index b5f5df45..1c741b25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -607,8 +607,8 @@ demo_clients += \
weston_simple_shm_SOURCES = clients/simple-shm.c
nodist_weston_simple_shm_SOURCES = \
- protocol/xdg-shell-unstable-v6-protocol.c \
- protocol/xdg-shell-unstable-v6-client-protocol.h \
+ protocol/xdg-shell-protocol.c \
+ protocol/xdg-shell-client-protocol.h \
protocol/fullscreen-shell-unstable-v1-protocol.c \
protocol/fullscreen-shell-unstable-v1-client-protocol.h
weston_simple_shm_CFLAGS = $(AM_CFLAGS) $(SIMPLE_CLIENT_CFLAGS)
@@ -618,8 +618,8 @@ weston_simple_damage_SOURCES = clients/simple-damage.c
nodist_weston_simple_damage_SOURCES = \
protocol/viewporter-protocol.c \
protocol/viewporter-client-protocol.h \
- protocol/xdg-shell-unstable-v6-protocol.c \
- protocol/xdg-shell-unstable-v6-client-protocol.h \
+ protocol/xdg-shell-protocol.c \
+ protocol/xdg-shell-client-protocol.h \
protocol/fullscreen-shell-unstable-v1-protocol.c \
protocol/fullscreen-shell-unstable-v1-client-protocol.h
weston_simple_damage_CFLAGS = $(AM_CFLAGS) $(SIMPLE_CLIENT_CFLAGS)
@@ -649,8 +649,8 @@ if BUILD_SIMPLE_EGL_CLIENTS
demo_clients += weston-simple-egl
weston_simple_egl_SOURCES = clients/simple-egl.c
nodist_weston_simple_egl_SOURCES = \
- protocol/xdg-shell-unstable-v6-protocol.c \
- protocol/xdg-shell-unstable-v6-client-protocol.h
+ protocol/xdg-shell-protocol.c \
+ protocol/xdg-shell-client-protocol.h
weston_simple_egl_CFLAGS = $(AM_CFLAGS) $(SIMPLE_EGL_CLIENT_CFLAGS)
weston_simple_egl_LDADD = $(SIMPLE_EGL_CLIENT_LIBS) -lm
endif
@@ -661,8 +661,8 @@ weston_simple_dmabuf_drm_SOURCES = \
clients/simple-dmabuf-drm.c \
clients/simple-dmabuf-drm-data.h
nodist_weston_simple_dmabuf_drm_SOURCES = \
- protocol/xdg-shell-unstable-v6-protocol.c \
- protocol/xdg-shell-unstable-v6-client-protocol.h \
+ protocol/xdg-shell-protocol.c \
+ protocol/xdg-shell-client-protocol.h \
protocol/fullscreen-shell-unstable-v1-protocol.c \
protocol/fullscreen-shell-unstable-v1-client-protocol.h \
protocol/linux-dmabuf-unstable-v1-protocol.c \
@@ -679,8 +679,8 @@ if BUILD_SIMPLE_DMABUF_V4L_CLIENT
demo_clients += weston-simple-dmabuf-v4l
weston_simple_dmabuf_v4l_SOURCES = clients/simple-dmabuf-v4l.c
nodist_weston_simple_dmabuf_v4l_SOURCES = \
- protocol/xdg-shell-unstable-v6-protocol.c \
- protocol/xdg-shell-unstable-v6-client-protocol.h \
+ protocol/xdg-shell-protocol.c \
+ protocol/xdg-shell-client-protocol.h \
protocol/fullscreen-shell-unstable-v1-protocol.c \
protocol/fullscreen-shell-unstable-v1-client-protocol.h \
protocol/linux-dmabuf-unstable-v1-protocol.c \
@@ -717,8 +717,8 @@ nodist_libtoytoolkit_la_SOURCES = \
protocol/text-cursor-position-client-protocol.h \
protocol/viewporter-protocol.c \
protocol/viewporter-client-protocol.h \
- protocol/xdg-shell-unstable-v6-protocol.c \
- protocol/xdg-shell-unstable-v6-client-protocol.h \
+ protocol/xdg-shell-protocol.c \
+ protocol/xdg-shell-client-protocol.h \
protocol/pointer-constraints-unstable-v1-protocol.c \
protocol/pointer-constraints-unstable-v1-client-protocol.h \
protocol/relative-pointer-unstable-v1-protocol.c \
@@ -966,6 +966,8 @@ BUILT_SOURCES += \
protocol/fullscreen-shell-unstable-v1-client-protocol.h \
protocol/xdg-shell-unstable-v6-protocol.c \
protocol/xdg-shell-unstable-v6-client-protocol.h \
+ protocol/xdg-shell-protocol.c \
+ protocol/xdg-shell-client-protocol.h \
protocol/ivi-hmi-controller-protocol.c \
protocol/ivi-hmi-controller-client-protocol.h \
protocol/ivi-application-protocol.c \